JKOwners Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
237 Posts
Discussion Starter #1
Maybe someone can help me out with a problem. Symptoms: ABS, e-brake, EPS/BAS and skidding car lights all come on about 100' into a drive.

Evaluating: I read codes. I had:

- C2200 Abs module integral
- B1638, B1630 Right high & low beam control circuit high
- B1634, B162C Left high & low beam control circuit high
- U0184 Lost comm with radio

I cleared the codes and they came back right away once I started it up. I have done some reading and the trucklites headlamps obviously contribute to the associated codes but they've been no problem until yesterday (after a few months use). I also read a wheel speed sensor can cause most of the lights but not likely to cause the e-brake light to come on. They did all come on at the same time while driving and still do.

Any suggestions or ideas on causes? If you suggest wheel speed sensor, have you seen ALL these lights caused by it or just some? If you suggest the headlamps, same question. Thanks for any info you guys might have.
 

·
Comfortably Numb
Joined
·
12,289 Posts
Easiest way to check if it's a wheel speed sensor is to set the cruise control and see if it switches off on its own. I got all the lights you indicated but not the codes you got. If that is the problem DO NOT buy from a dealer. AutoZone or NAPA.
 

·
Registered
Joined
·
13 Posts
Same lights on mine. Was a loose ground. Didn't seem loose. But after removing the battery cables, cleaning and tightening securely all my lights went away. And note- the dealer couldn't find the issue.
 

·
Registered
Joined
·
1 Posts
C2200

C2200 Code appeared. Took it to my mechanic. They traced it back to the Electronic portion of the the ABS Module. Replaced that portion. They programmed the module again- No more lights or C2200 code. Its takes a little longer to calibrate if youre rolling 35's like I do. $695 for that. Dealer would have been closer or over 1K.... Helps that mechanic owns two jeeps and knows these things in and out. I have a 2008 Rubicon 3.8L 3" Lift
 

·
Registered
Joined
·
224 Posts
Same thing happened to me. I pulled C2200 code. I replaced all brake fluid, which was black. We'll see if driving around tomorrow will fix it. If not I guess I'll be replacing the ABS control module.
 
1 - 7 of 7 Posts
Top