JKOwners Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
179 Posts
Discussion Starter #1
so I have the rugged ridge pillar pod with one rocker switch in it that controls the led pods on my windshield just recently I bought a 20" led bar for my bumper and another switch and wire harness. I mounted my light bar then connected my ground and power from my relay and then ran the wire for the switch inside my jeep. The wire harness had already came with a switch already connected so I just cut that switch off and it revealed a red black and yellow wire. I connected the red and black wire to my switch the yellow I left alone and the connected a wire that leads to the other switch cause that switch has. A wire that runs to my accessory wire so the switches won't stay on when the jeep is off. My problem is that the switch lights up and works but my led bar does not I connected a multi meter to the two wires that lead to my led bar and I get nothing so I'm wondering if it's the relay? Or something else? any help is appreciated and ask questions if I didn't make any of this clear
 

·
Premium Member
Joined
·
1,147 Posts
Do you know where the red yellow and black wires actually go in the harness?

I assume from your description that you are using accessory power to power the switch and relay circuit so it is on key power. Maybe you should be using the yellow and black wire instead of the red and black?

What brand light bar is it? And I assume you are using the harness that came with it? What switch are you using in place of the included one?

Is the relay a simple four post with a plug in the harness? If so you can pull the relay and look for a diagram on it. It should show which terminals are which. You could check for 12V between pins 85-86 on the harness side when you have the switch turned on. What color wires go to those positions in the harness? Can you feel/hear the relay click when you flip the switch?
 

·
Registered
Joined
·
179 Posts
Discussion Starter #3
I found out that it was a faulty wire harness. It was one of those cheap harnesses on Amazon but they sent me a new one and it works great now. My relay was not clicking on at all
 
1 - 3 of 3 Posts
Top