JKOwners Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
107 Posts
Discussion Starter #1
Ok im sure this has been posted but here ya go anyway :innocent: I have the standard 3.5 lift from Rubicon Express and the front end has rescently developed very bad sqeaks. it sounds awful, and being that none of it has grease serts i dont know what i can do . WD40 wont help, I have read where people has inserted grease into bushings with heavy syringes . So tell me what you have done or tried to stop it. At this point i will do about anything. :beer:
 

·
Registered
Joined
·
8,652 Posts
Ok im sure this has been posted but here ya go anyway :innocent: I have the standard 3.5 lift from Rubicon Express and the front end has rescently developed very bad sqeaks. it sounds awful, and being that none of it has grease serts i dont know what i can do . WD40 wont help, I have read where people has inserted grease into bushings with heavy syringes . So tell me what you have done or tried to stop it. At this point i will do about anything. :beer:
Is very likely that you might need new bushings.
 

·
Registered
Joined
·
36 Posts
The standard kit uses the stock control arms so as long as they were good before you did the lift those should be fine. The only bushings that are replaced in the standard kit are the front lower track bar bushings and the rear sway bar link bushings. Try some white lithium grease on those points.
 

·
Registered
Joined
·
8,652 Posts
The standard kit uses the stock control arms so as long as they were good before you did the lift those should be fine. The only bushings that are replaced in the standard kit are the front lower track bar bushings and the rear sway bar link bushings. Try some white lithium grease on those points.
The stock bushing dont hold up that well even in a stock vehicle...
 

·
Registered
Joined
·
5,114 Posts
i am going to bring this thread back to life for a few moments.... having this problem.... with this kit...... pleeease adv what people are doing since this thread is a year old and we prob have more info!
 

·
Registered
Joined
·
729 Posts
first u need to have someone stand outside and flex it or otherwise cause the noise and find out exactly where its coming from. then there will be a number of fixes im sure.
 

·
Registered
Joined
·
1,669 Posts
Perhaps now that RE has re-opened maybe they have better parts and you can buy an upgrade... Otherwise I would look for new bushings.
 

·
Registered
Joined
·
255 Posts
Go through all the pivot points one by one; lube and test to see if you still hear sqeaks, then move on to next pivot point. Even if you're using WD-40, it ought to quiet the squeak long enough to isolate the noisy parts that might need replacement.
 

·
Premium Member
Joined
·
1,453 Posts
Knob on the dash

Ok im sure this has been posted but here ya go anyway :innocent: I have the standard 3.5 lift from Rubicon Express and the front end has rescently developed very bad sqeaks. it sounds awful, and being that none of it has grease serts i dont know what i can do . WD40 wont help, I have read where people has inserted grease into bushings with heavy syringes . So tell me what you have done or tried to stop it. At this point i will do about anything. :beer:
There is a knob on the dash for that. You turn it clockwise. If you can still here the noise then turn it a little more. The knob should be on the left side of the radio.
 
1 - 9 of 9 Posts
Top