JKOwners Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
I have a 2008 Unlimited Rubicon and my turn signal seems to have a few gremlins. My left turn signal started flashing quickly periodically. I checked the bulbs and even switched the rear ones from the left side. It would occasionally go a couple of days with no issues and then, seemingly randomly go back to flashing quickly. Yesterday, for no apparent reason, other than I replaced the right side marker, the problem switched to the right side. Without starting the engine I placed the key in the on position and turned on the right blinker and it blinked normally the first time, but when I turned the right blinker off then back on the problem came back. I turned the key off and then back on and it again worked properly the first time, but then went back to blinking fast. Today the problem has moved back to the left side. The front blinkers work and the right rear tail light works. The left tail light doesn't work. When its working everything works the way it should, but when it starts blinking fast the issues begin. Any thoughts on how to fix it would be greatly appreciated. Thanks
 

·
Research, bro!
Joined
·
2,219 Posts
I had fairly similar turn signal issues a couple of years back. Most likely the turn signal switch which I ended up replacing on mine. Mopar #68041485-AD. Easy to install yourself.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #3
My research so far suggests you're probably right, but I was hoping it might be something a little bit cheaper.
 

·
Registered
Joined
·
1,886 Posts
When the problem presents, see which light isn't flashing. Then, wiggle the wires for that light.

Most of the time, when it's not a burned out bulb, it's a problem with a ground or power connection at the light fixture.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #5
It just seems weird that it would switch from one side to the other. Where are the rear lights grounded at?
 
1 - 6 of 6 Posts
Top