JKOwners Forum banner

1 - 18 of 18 Posts

·
Banned
Joined
·
3,226 Posts
Discussion Starter #1
Not sure if this had already been discussed but I thought I would share just in case.

I had a problem with my 2007 JK starting. At first, it seemed like sometimes I would turn the key and it would keep turning over and not start so I would reach down, turn the key off and try again and it would fire right up the second time. After a few times I just let it go and after about 2-3 seconds of turning pver it would start.

Took it to the stealership and they detirmened tha there was a TSB (08-023-07) and replaced the cam shaft sensor. So far no problems. :beer::beer:

Also, I got mt G40 recall taken care of. Gotta love new models! :thefinger:
 

·
Broker by the Minute
Joined
·
3,825 Posts
Any idea if the crank position sensor is just an automatic on the TSB or is all models? I'd almost bet it's for the auto's.
 

·
Registered
Joined
·
1,599 Posts
I'm glad that I found this thread. On the way home from trading in the H3 and getting the Rubi on Thursday I suffered a "disappointment". I drove the 70 miles from the dealer to home and stopped for some errands enroute. When I started the truck back up the ESP and the Check Engine lights came on and didn't go out. :bawling: :pissed:

I took it to the local dealer the next day and both lights went out when I drove into the service bay (naturally :shaking:). I gave the truck to them anyway, just to be safe. Well they want and looked at it. And then they keep looking... and looking... and looking... and I was none too pleased that my truck with only 102 miles on it was in the shop ALL DAY after having owned it for less than 24 hours.

Ultimately the issue turned out to be a bad crank shaft sensor and bad cam shaft sensor. I chalked it up to poop happens and decided to move on. Not too impressed, but moving on. This morning while having my breakfast I read this post and it made me feel MUCH better about what had happened. Its a known issue, they have a bulletin, and its taken care of. :bounce::grinpimp::beer:
 

·
Banned
Joined
·
3,226 Posts
Discussion Starter #5
Any idea if the crank position sensor is just an automatic on the TSB or is all models? I'd almost bet it's for the auto's.
I have no idea but I woulod be willing to bet with you but I have found with this JK I am usually wrong, lol
 

·
Registered
Joined
·
1 Posts
Wow, I can't believe this is still a Jeep problem. I had an 89 Cherokee and a 2000 Cherokee and both had the same problem with the crankshaft position sensor. Now I've got my 2007 Rubi, which is taking a little while to turn over before firing up, and I'll bet it's gonna end up being the same issue. So 20 years, and no progress there. hahaha
 

·
Registered
Joined
·
5,199 Posts
My JK failed to start today. Cranked over just fine, just wouldn't fire up at all. Wonder if it's the same thing? Either way, it was towed and will be at the dealership tomorrow.
 

·
Banned
Joined
·
3,226 Posts
Discussion Starter #8
Dang, sorry to hear about that Phil.


Every time mine would start it is just sometimes it would take longer then it should. I think I remember the TSB saying something about people attempting to start it and it would turn over but not fire up so maybe it is the same just more sever??

Keep us posted with the results.
 

·
Registered
Joined
·
5,199 Posts
I think I remember the TSB saying something about people attempting to start it and it would turn over but not fire up so maybe it is the same just more sever??
Yeah, from what I can gather other people just had a delay in starting or had to try it a couple of times, but mine was just not going to start. I'm hoping it's something simple, or at a minimum they find it, and not one of these ongoing situations that keeps happening. A few years ago, I had a H1 that left me stranded 12 times, it eventually turned out to be a rivet that had rubbed into the wiring harness and was shorting out every so often and blowing the TCM.
 
A

·
Guest
Joined
·
0 Posts
Hopefully it’s something definitive Phil. I had a ford exploder than had all types of intermittent electrical problems. I hate getting stranded :pissed:
 

·
Banned
Joined
·
3,226 Posts
Discussion Starter #11
It is funny (well, not very funny) How people can handle broken shafts and all sorts of other major issues on a trail but a small short in the wiring stops 'em dead in thier tracks! :D


I hate wiring :laughing:
 

·
Registered
Joined
·
5,199 Posts
One my expectations was that the fault would not happen when my vehicle got to the dealer. Sure enough it started fine, and as the computer showed no codes, that is as far as they will check it. I told them about the cam shaft sensor TSB and they weren't interested, so guess I'll take care of that myself. If I don't I suspect I'll be stuck again waiting for a wrecker...
 

·
Registered
irate4x4 dot com
Joined
·
1,795 Posts
One my expectations was that the fault would not happen when my vehicle got to the dealer. Sure enough it started fine, and as the computer showed no codes, that is as far as they will check it. I told them about the cam shaft sensor TSB and they weren't interested, so guess I'll take care of that myself. If I don't I suspect I'll be stuck again waiting for a wrecker...
:shaking:

figures

There has to be some idea of why it wouldn't throw a code, but also wouldn't try to hit. Maybe the lift kit caused it.;)
 

·
Registered
Joined
·
5,199 Posts
I thought it may happen, but was pretty sure it wouldn't start as i tried for 45 minutes.


There has to be some idea of why it wouldn't throw a code, but also wouldn't try to hit.
The service writer said if it was the camshaft sensor that it wouldn't throw a code, but without them been able to replicate it, they couldn't do the TSB.


Maybe the lift kit caused it.;)
I'm sure they have that excuse already pre-written in "Reasons for fault" :D
 

·
Registered
irate4x4 dot com
Joined
·
1,795 Posts
The service writer said if it was the camshaft sensor that it wouldn't throw a code, but without them been able to replicate it, they couldn't do the TSB.
Here is Dealer Service logic for you. There is a TSB.... a customer has to have their vehicle towed in due to something likely related to that TSB and instead of performing the fix related to it.... their position is to say it can't be replicated at this time and send you on your way only to likely leave you stranded once again.

There is something seriously wrong with the Chrysler dealer service network.
 

·
Registered
Joined
·
5,199 Posts
It's not very logical is it? Also it is likely to cost them more in the long run, having to pay to have it towed in a few more more times before they can replicate it and then do the TSB.
 

·
Registered
irate4x4 dot com
Joined
·
1,795 Posts
It's not very logical is it? Also it is likely to cost them more in the long run, having to pay to have it towed in a few more more times before they can replicate it and then do the TSB.
Cost much more. It costs more than the initial costs related to fixing it. Ratings associated with repairs due to dealer visits, customer satisfaction, employee time associated with spending extra time on one issue.

It would be slightly different if you drove it in and said I "hear" something. But having it towed in with a description of not cranking after being left stranded is a different story.
 

·
Banned
Joined
·
3,226 Posts
Discussion Starter #18
The service writer said if it was the camshaft sensor that it wouldn't throw a code, but without them been able to replicate it, they couldn't do the TSB.
I did not not have any code when I was having the issue with mine, that I could see anyways. I did not throw a CEL and my OBDII scanner did not read any other logs. Of course, the one I have for this vehicle is really basic.

I wish somebody out there would crack the Jeep ECU. Maybe somebody has on one of the Dodge forums and maybe it will translate over to the JK?? Anybody heard of anything???

I was driving an Evo before this and there is a group of people who cracked the computer and is doing most the work as an open source project. I understand Hex code, scripting and things like MUT tables to have fun with the Jeep ECU. I just don't know anything about dismanteling codes and locating ports. Imagine the fun we could have! Especially considering that everything on the Jeep is controlled by the ECU like Lockers, and the the brakes :D:beer:
 
1 - 18 of 18 Posts
Top