JKOwners Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 2008 jeep wrangler rubicon. The sway bar disconnect light keeps flashing and I cant get it to go off. What is the fix for this? Thanks, Dale
 

·
Registered
Joined
·
34 Posts
Sway bar light:

Off: Sway bar connected
Slow flash: State change in process (if it gets stuck in this state is likely a mechanical issue such as binding due to water having got in and washed off the grease)
Faster flash: Sway bar fault. This occurs if the swaybar logic board is not communicating with CAN-bus C or the board is communicating but reports a faulted state. Check for 12V power between either of the 2 medium pins in the harness and the one giant pin. Should be there regardless of ignition state. If there is no power check fuse (J11 maybe? its a 30A). If there is power your best bet is to take the system apart ASAP and get all the water out (and there WILL be water). Odds are good you're already f*cked though.
On stead: Sway bar disconnected.

If you can't get it working you can buy an entire new assembly from Jeep for upwards of $1500 (they don't sell just parts) or a manual disconnect kit for much cheaper (you can have dash light reprogrammed to stay off).

Other solutions are more involved but potentially better depending on your goal. You'll have to be comfortable messing with electronics to attempt but search around... Several here and other sites have dug really deep and come up with some interesting solutions that fix the issue permanently and upgrade functionality. I am getting ready to attempt one myself... Thread is still on page one.

EDIT: If you clean it up and get it working seal the entry location for the bar at each end with silicon RTV. It has rotary style seals which go bad and can't be bought separately but the movement of the swaybar at that point in negligible and the silicon will easily give that much without issue.
 
1 - 4 of 4 Posts
Top