JKOwners Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
1,359 Posts
I got mine last week. It's just as I expected, although the locker controls are not available yet.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #6
I have had it for a while.

It gives a little kick.... Nothing too crazy. I got it as a beta tester so it was cheap. Not sure I'd pay $350 for it
What year JK have you got ?

What difference(s) have you noticed ?
 

·
Registered
Joined
·
35 Posts
Holy crap! The same thread on every single jeep forum!
 

·
Registered
Joined
·
1,359 Posts
My butt dyno says it's not a huge gain (I'm running the 93 octane tune) Supposed to be plus 30hp and 30lb/ft.
I notice the biggest difference on uphill grades. I am able to maintain speed without downshifting where I would have had to grab a new gear before. Overall I'm pretty pleased. (2013 JKU Rubicon 6-speed manual, stock drivetrain for now)

Being able to use the factory fog switch with my high beams was a nice unexpected addition, and paving the way for a gear swap and some 37's I think this unit will eliminate the need for a Procal. I paid ~300 for it on Amazon. Overall, I'm pretty happy.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #11
My butt dyno says it's not a huge gain (I'm running the 93 octane tune) Supposed to be plus 30hp and 30lb/ft.
I notice the biggest difference on uphill grades. I am able to maintain speed without downshifting where I would have had to grab a new gear before. Overall I'm pretty pleased. (2013 JKU Rubicon 6-speed manual, stock drivetrain for now) .
How is the throttle response and everyday drive-ability ?

How is your off idle throttle response now ?
 

·
Registered
Joined
·
1,359 Posts
How is the throttle response and everyday drive-ability ?

How is your off idle throttle response now ?
It's "acceptable", but a little different. I especially notice a difference when driving through a 25 MPH zone. At almost no throttle there is a fine line between idle, and go, and it does it in any gear. It's almost like it's either idle or 5% throttle, but nothing in between. It's a little strange, but I chalked it up to the ECU needing to learn a little longer (I don't drive it much so I have less than 100 miles on it so far). All and all the throttle response and drive-ability is fine, and the weirdness I have is so very slight an issue, I don't worry about it much. I figure either the ECU will "learn" over time or I'll get used to it.
 
1 - 12 of 12 Posts
Top