JKOwners Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hi all, when i was tightening the screws during installation of my winch i bridged the battery and melted and broke off the screw on the stock block terminal positive side. It's the piece of metal that has 3 bolts. i can't use one of the bolts anymore. I would like to replace it, but i can't seem to find the part# for it.

Also, recently i'm not sure if it's related, but the AC seems to cut off when i'm driving. It does not turn back on until i turn the dial all the way off and then turn it back on. Everything is tightly secured.

Electrical mods
Dually fog lights spliced into the stock wiring with 10 ohm resistors so they don't flash. (not on when the ac cuts off)

winch connected to one of the 3 bolts on the block.

neither are engaged when the ac shuts off.

i have a 2014 jku

please advice
 

·
Super Moderator
Joined
·
6,239 Posts
picture of what you're referring to would help; not to be unhelpful or rude but that description makes very little sense ( "...stock block terminal positive side..." ??)
are you trying to say you stripped or broke the battery positive-post crimping bolt?
Also, consider an sPOD or fuse panel from Painless ( or, DIY if you're electro-mechnically inclined)

check out ---> http://www.painlessperformance.com/webcat/57000

anyway , i digress; slow it down, one issue at a time and picts will get you much further on here when seeking assistance or having trouble describing the issue you're encountering. Worth a thousand words is an understatement.
:)
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
sorry, this distribution piece

found online, it's dark here or i'd take a picture of mine, the bolt that broke is the one with the small black wire, closest to the negative terminal
 

·
A JKO DICK
Joined
·
3,690 Posts
I replaced mine with theses: http://www.quadratec.com/products/17004_9001.htm

But you can double up the connections on one post to get you going. You can also usually find an assortment off battery terminals and connectors at local auto parts stores.
 

·
Super Moderator
Joined
·
6,239 Posts
^X2
I used Heavy Duty Marine w/ gold plated lead and they work as fine as the replacement models at AutoZone, AdvancedAuto or O'Reily's /Napa. the QTec that Assfrow uses are highly recommended and a good affordable choice once you've patched it up with a temp solution from parts store.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #7
ok so, i did double up connections, the AC issue is not relate correct? that's probably a bad relay, the dealer should replace
 

·
Super Moderator
Joined
·
6,239 Posts
it does not sound related but may I ask if the AC cutting-out began before or after your winch installation? I would certainly consider the relay as what the dealer should start with but the fact it comes on at full then back off and on after cycle of the switch seems odd; you don't wanna do anything to interupt the grounding on JKs they are so sensitive to electronically controlled changes or mods....but, i was interested in the order of this ac issue in all your modifications of leds and winch installation....
 

·
Registered
Joined
·
7 Posts
Discussion Starter #9
it was after the installation of the winch, but a few weeks after. not right immediately, i set an appointment with my dealer, but they are backlogged for a few weeks, i'll remove the wiring for the winch until between now and that time, i'll see if that is the issue.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #11
unfortunately it did. i'm going to see if i can find a junkyard to try and locate that terminal splitting piece.....

check the winch connections.....

then i'm out of ideas...
 
1 - 11 of 11 Posts
Top