JKOwners Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
7,281 Posts
Discussion Starter #1
well besides my leaking pinion seal and bad bearings I think I found out why my locker light is blinking.

Anyone know if they sell the parts on the right separately? You can see the groove that is cut into the metal that should not be there and the tab doing it is worn. :shaking:





I'm thinking I am screwed because I've heard most of the parts for the locker they dont sell separately and I dont even see it in parts diagram :shaking:
 

·
Registered
Joined
·
128 Posts
You are in luck! It is now time for a 60 upgrade!:bounce:
 

·
Registered
Joined
·
7,281 Posts
Discussion Starter #3
You are in luck! It is now time for a 60 upgrade!:bounce:
considering I maybe getting laid off soon thats not going to happen:shaking: even if I wasnt I wouldnt spend 6k+ on an axle now
 

·
Registered
Joined
·
128 Posts
Sorry to hear that. Your best bet may be to find one at a junkyard. I'd maybe start with a google search. Good luck.
 

·
Registered
Joined
·
840 Posts
Ugh, good luck Tim. Haven't had much luck with that rig lately, hope you can get just the parts you need. Keepin my fingers crossed for ya with work too :beer:
 

·
Registered
Joined
·
1,167 Posts
Just bend the tab so it hits in a new spot. All that bracket does is the keep the magnet from spinning. When I first opened mine up that little ear thing was barely in the slot...so I took a screwdriver and just bent it over. While your in there you might want to check to see if your plunger is in the right palce.
 

·
Registered
Joined
·
7,281 Posts
Discussion Starter #8
Just bend the tab so it hits in a new spot. All that bracket does is the keep the magnet from spinning. When I first opened mine up that little ear thing was barely in the slot...so I took a screwdriver and just bent it over. While your in there you might want to check to see if your plunger is in the right palce.
the magnet stops but that little ear is worn through half way and I dont know now much longer it will last :shaking:

Lockers been fine for 60K+ miles no blinking at all till now, I'm 99% sure plunger is it correctly.
 

·
Registered
Joined
·
2,073 Posts
Tim.. That sucks about both items.. Locker and maybe getting laid off.. You can get a whole locker as a replacement..

Here is the part number I think for the whole locker for a 2007.. 68003553AA Discount Mopar Parts has it listed for $618.. Better then spending a butt load on a new axle..
 

·
Registered
Joined
·
3,730 Posts
Tim,
Not really sure how easy it is to take just that part out, but it would be really simple to fix it. Just cut it down and weld on a new tip and grind it smooth....

You could even do it with everything put together if you were careful with the slag and heat of the weld....
 

·
Registered
Joined
·
7,281 Posts
Discussion Starter #12

·
Registered
Joined
·
7,281 Posts
Discussion Starter #15
Hey Tim my rear locker is screwed up at the bearing surface where the axle shaft splines are but the rest of it should be fine. Let me know
Did you replace it?
 
1 - 17 of 17 Posts
Top