JKOwners Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
375 Posts
Discussion Starter #1
2 weeks ago we went out for a little trail ride (nothing major) and I was in the lead and basically was the ice-breaker at every water hole (when I say "HOLE" I mean 18" deep max)...There was probably 3/4"-1" of ice at each "HOLE"...On our way home I noticed that I was starting to saw the steering back and forth just to keep it on the road...They next day I crawled under the JK and looked everything over and didn't see anything that looked like it was broke, loose, or bent...

It has slowly gotten worse and I can't seem to figure it out...Tonight on my way home from work to was swaying back and forth so bad that I had to slow down below 55mph...If you guys have any ideas please let me know...I would greatly appreciate it...Thanks.

BTW...Last May when I had my state inspection done I needed lower ball joints and the shop installed just the lowers and they were MOOG's...Not sure if the uppers may be bad now...
 

·
Official Monkey Business
Joined
·
12,215 Posts
X2, this is probably toe. It doesn't take much to bend a stock tierod and it doesn't take much bend to mess toe up.
 

·
Registered
Joined
·
375 Posts
Discussion Starter #4
Well I will check it over in the morning...If my tierod is bent what should I replace it with (less than $400)????
 

·
Premium Member
Joined
·
4,937 Posts
Well I will check it over in the morning...If my tierod is bent what should I replace it with (less than $400)????
U can certainly get a nice aftermarket tie rod (poly/RK etc) for less than $400.

Is this thing on?.....
 

·
Registered
Joined
·
375 Posts
Discussion Starter #6
Well, I have found a couple things so far...I will download pics later today...

#1. About 3 months ago I received a Rough Country Dual Steering Stabilizer kit as a gift...I installed it and have about 3500 miles on it now...One bracket on the tierod pass side is bent...I can see that the bracket that mounts to the axle and has both stabilizers mounted has been rubbing the tierod also...

#2. I checked the toe and it is 3/16" difference from front to rear...However, I did notice tire wear on the inner pass side tire...I'm rotating my tires at this time so I will see if I notice any difference and I will be watching for any odd wearing since this rotation...

#3. My rear upper driver side control arm (TearFlex) is shot...The threads are worn and the jam nut is stripped...I have to look into just buying a replacement arm or possibly the heim end...

I know it would be better to add pics to this right now but I have to find the cord to the camera and I'm burning daylight right now...LOL
 

·
Registered
Joined
·
226 Posts
Tank, On #2: 3/16th which way?

The front should be narrower than the back.

If that is true, 3/16 is too much. It should be no more than 1/8th (i know a 16th is tough to tell using a tape measure)

I the rear is narrower then it is way out spec and would definitely cause what you are describing.

good luck!
 

·
Registered
Joined
·
375 Posts
Discussion Starter #8
Tank, On #2: 3/16th which way?

The front should be narrower than the back.

If that is true, 3/16 is too much. It should be no more than 1/8th (i know a 16th is tough to tell using a tape measure)

I the rear is narrower then it is way out spec and would definitely cause what you are describing.

good luck!
Yep the front was narrower then the rear...I have it adjusted to a rough 1/8 using a tape measure and doing it by myself...Time will tell...Thanks
 
1 - 8 of 8 Posts
Top