JKOwners Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
271 Posts
Discussion Starter #1 (Edited)
Ended up being a bad fuel pump!!!

- Sounds like the stall bug just hit me at approx 10,000 miles on a 2008. Happened yesterday doing about 65-70 on the intersate, happened numerous times where I had to pull off and it died. Restated after a few tries everytime and I would continue on. All electrical still worked though. Bad thing about it is all Jeep dealers in Central PA seemed to be closed on Saturday for service, I called about 5 of them. I filled up with gas and it ran good for about 62 miles and then started stalling again. Weird thing is this, sometimes when it was happening I would pump the gas and sometimes it would come back to life but most times it just plain died. Scary stuff here. I already filed a complaint today with the Feds about this. Hopefully I can get a re-flash Monday at a Dealer in Central PA so I can make it home to VA.

Anyone else with a 2008 have this problem yet???
 

·
Registered
Joined
·
441 Posts
Sounds different then the "stall bug".
 

·
Registered
Joined
·
3,608 Posts
The so called "stall bug" I believe is the driver and/or the onboard computer learning the driving habits of the owner...I stalled several times shortly after receiving my JK...a lot had to do with the way I engaged the clutch and at what RPM's I was doing so, from a dead stop....the problem has disappeared, and I no longer have to rev her up before I engage the clutch...I can take off easily in as little as 400 RPM...that's my take...
 
1 - 4 of 4 Posts
Top