JKOwners Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
387 Posts
Discussion Starter #1
2013 jeep JKU with 50,000 miles

airbag light came on about a year ago. within days, I got notification that my passenger airbag was recalled. took it in to the dealer, who replaced the airbag. light stayed on. they said it wasn't their problem.

it has been a while since I have done a long drive in my jeep, so I hadn't used cruise control in at least a month. I had the occasion to use it last week and nothing happens when I press any cruise control buttons. no indicator light on the dash, and it won't hold speed even if I try to set the cruise control blindly. at this point, between the airbag light and cruise control issue, I assume it must be the clock spring which is a known problem and under an extended warranty. so I took it back to the dealer two days ago.

they said it was in fact the clock spring, so they replace it under warranty. everything seems great on the drive home two days ago - airbag light is off, cruise control works, etc.

then driving to work the following day (yesterday) the check engine light comes on. I had my flashcal with me, so I pulled the codes:

P0128 thermostat rationality
P0579 speed control switch 1 performance
P0581 speed control switch 1 circuit high
p0591 speed control switch 2 performance

I've been having issues with a coolant leak, which turned out to be a crack on the thermostat housing. so I have that part on order along with a new thermostat. I assume that will fix the first code.

the strange thing about the speed control codes is that my thermostat still works just fine (I tested it on the drive home from work last night, and on the way in this morning).

I brought the jeep back in to the dealer today, and I've got a bad feeling their going to hose me. does anyone have experience with this? is it possible they just need to reset something in conjunction with the clock spring replacement and i'll walk away without paying a ton of money?
 

·
Registered
Joined
·
387 Posts
Discussion Starter #2
update... I just got a call from the dealership. apparently the tech just forgot to clear some codes that happened during the clock spring installation. strange that I didn't see the check engine light on when I picked it up Wednesday, but I guess things are good for now. I should have just cleared the codes myself.

thank you all for your prompt help and kind words :thefinger:
 
1 - 2 of 2 Posts
Top