JKOwners Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
966 Posts
Discussion Starter #1
Well I didnt get a hot UPS chic to deliver my goods, but I had a box show up today. THANX PHIL!!





Was going to try n do another retarded easy write-up as this was supposed to be an easy bolt-on deal. Supposed to be. . . .

Started out reaming the holes to 1/2" as stated in the instructions



Slid the brackets in w/o bolts. Supposed to adjust them later.



Then you rest the bumper on the frame, hop under and throw in the supplied nuts and bolts.



Well it started. The part of the bumper with the receiver was supposed to fit around the frame and use the existing holes to mount to. It wasnt close, too tight. Soooo went to ask my neighbor to borrow a grinder, he gave it to me for a pack of camels heh, score.



It still didnt fit. More grinding and at this point I stopped taking pix. More grinding, burned through the wheel that was on the grinder, had to go buy a new one. FINALLY got the damn thing to fit, holes dont line up. All of them were too low, meaning the bumper needed to come up, but if it came up anymore I would have to shave the bottom of my rear gate.

Sooo bumper back off, got my other neighbor involved, borrowed his scroll saw and thankfully he had a metal blade. Made the holes a little bigger WOO.

OK now we can get the 4 bolts through. . . . . and at this point I find out that the bolts on the side are about 1/2" off. Drop the bumper again and recruit the scroll saw for another go. Cut 1/2" into the pre existing holes in the frame (towards the front of the Jeep, making them elliptical) and made sure it lined up with the mounting bracket, Bingo.

It's on now, looks great, fits the 35" tire on the stock gate mount with a curly hair to spare, and the gate swings freely without rubbing on the bumper (It did at first b4 a 2nd go at reaming the holes on the rear)

I installed the Shrockworks bumper all by myself with nothing but a wrench and a ratchet. The fitment on this thing was WAY off, but I got to break a sweat I guess, buy my neighbor a beer for the help, and make my girlfriend cringe with the showers of sparks from the grinder. But its on. I would like to have gotten a shrockworks for the rear but from what I hear they are very very backed up and I think this one looks like it belongs better than some of the others Ive seen.

Fitment aside, the bumper looks great, welds look strong, shackle mounts are through the bumper and welded on both sides like the Shrocks, just wish it would have actually fit out of the box, oh well. Here it is.







 

·
Registered
Joined
·
3,201 Posts
Looks great. Sorry it was a bear to put on. You should call them and let them know so they can fix it for the rest of us. :beer:

Do you know if they ever started shipping the carrier for that bumper?
 

·
Registered
Joined
·
966 Posts
Discussion Starter #3
I wonder if its a QC issue. Did anyone else with this bumper have the same issues? It does look good and if it bolted right on I would give it 5*.

As far as the carrier I don't know for sure. I know it's listed on their website, Phil would probably now better than I. I bought mine from Trail Duty.

I would like to take some welding 101 here at the community college and make my own tire carrier. Figure a bumper might be a tall order for a 1st weld but a tire carrier might be more do-able.
 

·
Registered
Joined
·
961 Posts
Nice looking bumper; crazy that it didn't just bolt on, sounds like a real pita... I have seen several of the carrier version on the interweb, so they do have them ready...
 

·
Registered
Joined
·
292 Posts
I have the Smittybily XRC front and rear bumpers on my 08 4dr yellow Rubi. They were both a p.i.t.a. to install and required both grinding and drilling to fit properly. The rear hatch is still a little too close for comfort so I will be adjusting it yet again. The products look great besides a few complaints. The textured powdercoat finish on the front bumper has already started to flake off in some areas and the hoop on the front bumper blocks the turn signals. I really like the bumpers, but if I had known these were things I would run into I may have looked harder at other options.
 

·
Registered
Joined
·
155 Posts
Good writeup/quite informative.

When they fit well right out of the box that's always a big plus :smokin:, when they dont - it can be a real :pissed:pita.

Thanks :beer:
 

·
Registered
Joined
·
5,199 Posts
Looks great :smokin:

Sorry to hear of the fitment issues, first time I'd heard of it, but sounds like it may be common. I wonder if the "bracket" section got tweaked in shipping causing the issue? I've had similar issues with other brands and it's often turned out to be shipping damage, although it isn't at first apparent.
 

·
Registered
Joined
·
966 Posts
Discussion Starter #8
yeah it seems like the bottom bracket that has the receiver hitch was off, not by much, if it was angled backwards (towards the rear of the jeep) just a little bit it would fit alot better. Also maybe a little wider, had to grind mount on the bumper and grind the welds on the rear frame cross member flat. Dont think it could have happened from shipping, It was packaged really good and the part that mounts the cross member is also braced all the way through by the receiver.

The side mounts didnt line up (couldnt have been bent, the holes were simply not in the right spot) had to notch the existing holes in the frame about 1/4 to 1/2 inch. Its a great looking bumper, again, great welds, just not an easy bolt-on and it pretty close to the gate. If I dont lift up on the gate slightly it does scrape a tiny bit on the drivers side of the bumper. That could, and probably is also due to the weight of a 35" KM2 on the stock mount however.

All in all, for me it was worth it, just had to put in a little work to get it to fit, but the shrockworks front fit like it was made to fit, the smittybilt fit like it was eyeballed or like I said, maybe not very tight QC on their build specs.
 

·
Registered
Joined
·
1,658 Posts
My front bumper was an easy install.

The rear needed the holes reemed out a bit. I didn't have to grind the c channel like you did though.

I haven't seen any issues with the powder coat flaking yet.
 
1 - 9 of 9 Posts
Top