JKOwners Forum banner

1 - 20 of 25 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
It's highly probable I'm losing my mind but has anyone experienced a slow digital clock? I keep setting it ahead and within a few weeks it's running behind again. Ive seen Chrysler do some dumb stuff but this would take the cake if they managed to have a slow digital clock!
 

·
Registered
Joined
·
1,014 Posts
My stock and aftermarket JVC radio both did/do that.
 

·
Gunnery Sergeant USMC (ret)
Joined
·
22,098 Posts
Fucking conspiracy I tell ya. Why can't the ass clowns get with someone who can actually, Oh I don't know make watches that tell the correct time and have them design the clock in the jeep.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #9
I adjusted mine so it's is only 2 minutes behind in 2 months.
Yeah mine takes a while to get noticeably behind and by then I've forgotten that the problem exists and wind up being 5-10 minutes late to everything. Then I adjust it and the vicious cycle begins once again. I'm telling you it's some sort of sick sociological experiment!
 

·
Registered
Joined
·
11,065 Posts

·
Registered
Joined
·
184 Posts
My old Grand Cherokee was fast and my JK is slow. Jeep tried to fix it and overshot. Better luck next version.
 

·
Registered
Joined
·
44 Posts
I adjusted mine so it's is only 2 minutes behind in 2 months.
Inquiring minds want to know how you adjusted yours to only lose a minute a month. Mine loses 5 minutes in a month.
 

·
Registered
Joined
·
1,250 Posts
Think about what kind of EPIC engineering fail you have to achieve to result in a quartz clock that loses time like the Jeep does. Chrysler, you fail at time.

I have a 2010. Please tell me they've corrected this since then.
 

·
Registered
Joined
·
3,060 Posts
Think about what kind of EPIC engineering fail you have to achieve to result in a quartz clock that loses time like the Jeep does. Chrysler, you fail at time.

I have a 2010. Please tell me they've corrected this since then.
Let's see, our '08 Rubi did it, our '09 Rubi did and now our '12 Rubi does it.

Nope, not fixed and not likely to ever get fixed.
 
1 - 20 of 25 Posts
Top