JKOwners Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
9,127 Posts
Discussion Starter · #1 ·
I have been fighting my salt cell for a while. For the non pool, or those without a salt pool, its what makes chlorine so you don't have to add it constantly. Without chlorine algae will invade and make life hell.

Anyway.... I had to replace the chlorine generator last year I found one on the web for about $350 and still had problems. A little Google-fu returned a list of options with this one on top ----> "No Cell Power" seems as if it is a very common problem. I am using the Aqua-logic control panel that runs everything. I couldn't super chlorinate because of the no cell power indicator. After following the simple directions on the website I am back in business and didn't have to spend $600 on a new mother board. I already had the soldering iron and some flux core solder and it took longer to take the panel apart than it did to fix the problem.

So.... if you having this issue - don't buy anything until you check to see if it can be fixed via this method.

I found a vid on Youtube

Aqualogic Salt Water Chlorine Converter - No Cell Power Fix - YouTube

If you have not spent time on the "trouble free pool" website and are still wasting money at the pool store you need to check it out!! Save that money for Jeep parts!

Happy swimming!
 

·
Registered
Joined
·
9,127 Posts
Discussion Starter · #6 · (Edited)
65Vdub - my pool was right at 5yrs old when the salt cell went out. Then one of the pumps... then new filter screens. lol.

JK - do you have a booster pump? I have the little polaris 3900 and it gets after it. I kinda want the remote robot thingie but don't want to drop a grand on it when the little one works just fine. I just sweep the steps and seats and it does the rest.

Cpt - take the panel apart and see if that spot needs fixed. I would bet that is your problem. It happened to my neighbor and a buddy at work too. You can check out the salt cell / chlorine generator to see if it is working at most pool stores that sell the units. If it's broke check here for the best prices that I found.

I am going to install one of these things:

 

·
Registered
Joined
·
9,127 Posts
Discussion Starter · #7 ·
Sheesh that's expensive, I'm sure you have a nice inground pool, I just have a 16' above-ground, but it's hung in there for almost 5yrs now. Of course I modified, lol, the jeeper in me, it has an oversized pump, etc, but I still use the chlorine and it's always crystal clear. If I had an inground I'd still use chlorine. My brother-in-law used the salt system and he has a bit of trouble with his now and then but generally stays clear/etc.

Guess if I had an inground I'd consider the salt system though just for the obvious reasons.

Don't think I added one beneficial thing to your post Ron, but thought I'd drop in and say hey anyway, lawlz.:)
W'sup Sas!!

Salt is the only way to go...
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top