JKOwners Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
261 Posts
Discussion Starter · #1 ·
On a recent trip out I busted a sway bar link. No problem, order up some new ones from RK and then install. Well that's what I though anyway.

I have e-disco and the PP track bar brace.

Can anyone with the same or similar setup help me out with a close up photo of what you did here for the bottom link?

Also the upper bolt that came with the RK kit is slightly larger than the sway bars hole. Should the hole be reamed out or what? The stock bolts don't fit the heim joint and there is a lot of play so didn't want to reuse them.

 

·
Registered
Joined
·
98 Posts
You will have to ream out the sway bar hole just slightly...1/2" I believe. I have the PP weld on track bar bracket but have not installed it yet. I also have the RK sway bar links. Now that I look at it I see the problem since the links are much narrower than the stock links. Maybe you could find a metal spacer or jam nut to take up the slack. Hmm...I'll have to come up with a solution myself:(

Edit: I measured my RK link with the washer and nut and it stuck out exactly 1.5" which is about the same as the stock link by itself. This should fit but you may have to grind some off of the bolt end and you would not use the hole in the track bar bracket. You could also just fill the gap with some washers.
 

·
Registered
Joined
·
262 Posts
Similar setup, but mine is all welded in by DesertFab in the East Valley....give Todd a call.
He did the install/welding so I'm not sure if he had the same issues.

Here's a pic of mine if it helps:


PM me if you need more info.
 

·
Registered
Joined
·
261 Posts
Discussion Starter · #5 ·
Guys thanks for the responses. Hasn't been an issue running without it connected but I want to get them connected before I need to do any emergency maneuvers :)

JocKy- Thanks for posting up that pic. I was trying to put it back in the stock location but moving it solves all kind of issues. Hopefully I have the hardware laying around for the driver side somewhere.

river2c- 1/2" bit, check. The problem was definitely that the RK links are slimmer than stock. I checked and the hardware does not fit in that space for my setup, even when eliminating the plastic washer. Maybe you'll have different results since your using RK brace?

RK- I will give you a call next Monday in the AM if I don't figure it out this weekend. Thanks in advance for the support sir.
 

·
Registered
Joined
·
262 Posts
I have a RK 3.5 lift and I did have to order 7" pins (made for the 2.5" lift I think) from RK to get the sway bar to sit level. They shipped them quick and charged me like 20 bucks, but I already had the RK links. Just a side note if you are ordering RK links and don't have them yet.

Not sure what lift you have though.
 

·
Registered
Joined
·
3,175 Posts
Similar setup, but mine is all welded in by DesertFab in the East Valley....give Todd a call.
He did the install/welding so I'm not sure if he had the same issues.

Here's a pic of mine if it helps:


PM me if you need more info.
How do you disconnect those sway bar links before going wheeling? I have been meaning to ask someone this for a while. Mine have the cotter pin that you just pull prior, I just wanted to know how it worked for that style
 

·
Registered
Joined
·
94 Posts
I believe, may be wrong, that it is e-disco
 

·
Registered
Joined
·
3,187 Posts
Guys thanks for the responses. Hasn't been an issue running without it connected but I want to get them connected before I need to do any emergency maneuvers :)

JocKy- Thanks for posting up that pic. I was trying to put it back in the stock location but moving it solves all kind of issues. Hopefully I have the hardware laying around for the driver side somewhere.

river2c- 1/2" bit, check. The problem was definitely that the RK links are slimmer than stock. I checked and the hardware does not fit in that space for my setup, even when eliminating the plastic washer. Maybe you'll have different results since your using RK brace?

RK- I will give you a call next Monday in the AM if I don't figure it out this weekend. Thanks in advance for the support sir.
I had the same problem. I drilled out the poly bolt like the one that comes from RK. Then I glued some nylon washers together to fill the hole between the sway bar tab and the poly brace.

I will grab you a pic when I get back from Afghanistan. It was pretty easy to do. I didn't have shorter links to run. No issues either.
 

·
V8 dreams
Joined
·
3,573 Posts
OP did you ever figure this out? i'm needing a skinnier on bottom sway link...with the rk TB bracket on, the JKS links are too wide to disco like normal
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top