JKOwners Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
400 Posts
Discussion Starter #1
I have searched some threads already on this but this is really annoying. I have called safelite back and they are coming out monday but damn. When did they start taking the molding off around the wind shield? To me this doesn't make any sense what so ever, I would think all kind of debre gets inbetween the window and frame. Just a rant... I'm sure a lot of us on here have had to deal with this, but is there a good fix?
 

·
A JKO DICK
Joined
·
3,689 Posts
I have searched some threads already on this but this is really annoying. I have called safelite back and they are coming out monday but damn. When did they start taking the molding off around the wind shield? To me this doesn't make any sense what so ever, I would think all kind of debre gets inbetween the window and frame. Just a rant... I'm sure a lot of us on here have had to deal with this, but is there a good fix?
Our windshields are glued in. There is no "seal" other than the glue. Two of the four I've had wistled. The best fix I found was a speaker upgrade.
 

·
Registered
Joined
·
400 Posts
Discussion Starter #3
the sound is only there between 30-50 MPH. I know there are others than have installed some aftermarket molding to stop it. On another thread I saw that it's because of to large of a gap between the glass and the frame.
 

·
Registered
Joined
·
1,481 Posts
My factory windshield in my '08 didn't whistle. Had it replaced by Safelite and they didn't cut it properly, the gaps between the edge of the window and window frame were larger than factory because they cut the glass too small. I filed a dispute with USAA and had Safelite use an OEM glass and the problem went away. Use OEM glass when you can would be my advice.
 

·
Registered
Joined
·
1,175 Posts
There's a thread on Jeep forum about this. The fix was having the window mounted with no more than an 1/8" gap between the glass and frame at the top.
Installer argued the point, owner checked all the Jeeps on various lots. Owner found all the windows from the factory were mounted with the upper gap at 1/8" or less.
Installer remounted the glass with the requested spec, no more whistle.
 
1 - 6 of 6 Posts
Top