JKOwners Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I'm sure it's on here somewhere, but my searches are coming up nil. I've installed new Recon LED front turn signals and having issues w hyper flash. I first used the vampire style splice connectors sent w the lights for the resistors and they are crap! I rewired them for a better splice yet now I'm getting the first 5 flashes normal then fast. My question is do I need a higher rated resistor than what comes w the lights? They come w 25w8oh resistors.
Much thanks for advice.
 

·
Registered
Joined
·
87 Posts
I'm sure it's on here somewhere, but my searches are coming up nil. I've installed new Recon LED front turn signals and having issues w hyper flash. I first used the vampire style splice connectors sent w the lights for the resistors and they are crap! I rewired them for a better splice yet now I'm getting the first 5 flashes normal then fast. My question is do I need a higher rated resistor than what comes w the lights? They come w 25w8oh resistors.
Much thanks for advice.
You can actually get plug and play resistors from Ebay. I had the same problem with the Recon's and these solved the problem.

http://www.ebay.com/itm/BRZ-7443-7440-LED-FRONT-REAR-TURN-SIGNAL-LIGHT-BULBS-FAST-BLINKER-FIX-RESISTORS-/321448836893?pt=Motors_Car_Truck_Parts_Accessories&hash=item4ad7d7ff1d&vxp=mtr
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thanks. I had already ordered new resistors. Got them in today...the passenger side works, but the driver side now goes from not flashing to hyper. :/
I'm guessing maybe a loose connection, but aside from that I'm at a complete loss.
 

·
Registered
Joined
·
57 Posts
I have the same problem. I installed Anzo USA 861119. I was told by tech that there was no need to install the resistors. So, I installed then without the resistors. I had hyper flash on both sides. I installed the resistors, and every thing was fine for a month. Then I had the same problem as you. 5 or 6 good flashes, then hyper flash. I thought that the resistor was too small, but the passenger side never had a problem. I thought maybe the drivers side was getting too hot. I was going to install new bigger resistors, but I think I will try the fast fix from ebay. They are a little cheaper on Amazon though.
 

·
Registered
Joined
·
3 Posts
I'm having issues with recon led turn signals in 2013 wrangler. So converted all to all headlights tailights fog lights turns signals fender light…when I put the headlights on the recon turn signals stay lit and do not flash when the turn signal is on. Resistors are in but they don't play a part in this…with or without resistors if the headlights are on the turn signals won't work.
 

·
Registered
Joined
·
265 Posts
I got a set of these Recon turn signal from someone with no instruction. I wired the resistor to the outside wire and getting the hyper flash, does it need to wired into the ground wire as well.
 
1 - 6 of 6 Posts
Top