JKOwners Forum banner
21 - 40 of 49 Posts

·
Registered
Joined
·
279 Posts
Thanks, looks like it might be a problem with the TIPM. Turns out I'm 3 weeks out of warranty for electrical issues so time to hit the wreckers.
 

·
Registered
Joined
·
3 Posts
I had the same issue pop up last night. 2010 Mountain with 38k. Headlights would turn on, but immediately turn off. If I left the switch in the on position, they would flash after a few seconds a few more times, but would eventually stay off. I checked for DTC codes and nothing showed up. I just bought it Friday from a dealer but I checked the oil level and it was good. It was telling me an I needed an oil change, so I went ahead a cleared that. The lights still wouldn't stay on.

I disconnected the batter for a while and that seemed to correct the issue. They at least stayed on when I drove into work this morning. Everything on the Jeep is stock so I doubt the bulbs are higher wattage. If the start flaking out on my again, I check to see if they arent factory.
 

·
Registered
Joined
·
279 Posts
My lights have been working for a month now, didn't do anything. Lets hope this problem is the same as the one I had with my wipers a couple of years ago, they would just turn on for no reason and then that stopped too. Ghosts are fuckers!
 

·
Registered
Joined
·
3 Posts
Well I had my light problem show back up this morning. I had to use my fogs to drive into work this morning. I cant keep disconnecting my battery. HELP!
 

·
Registered
Joined
·
1,272 Posts
I had a bad flicker with my passenger trucklite. I wrote it off to TIPM till it got worse. Ended up being a bad connection at the plug. Check your wiring and plugs for any loose connection. I had also had power steering fluid get on the connector. I rerouted the wiring to be further toward the side and all is good so far.
 

·
Registered
Joined
·
3 Posts
Thanks for the idea bgall, but it is not acting like something is "shorting out". Its acting like the computer is doing it. The period the lights are on and off is exactly the same each time. Turning the switch to the off position and back on immediately starts the process over. It just seems too perfect to not be computer controlled.
 

·
Registered
Joined
·
1,272 Posts
Thanks for the idea bgall, but it is not acting like something is "shorting out". Its acting like the computer is doing it. The period the lights are on and off is exactly the same each time. Turning the switch to the off position and back on immediately starts the process over. It just seems too perfect to not be computer controlled.
So did mine. The flicker was almost perfectly in sync with what I would expect from the computer pulsing power.
 

·
Registered
Joined
·
830 Posts
my 08 with stock bulbs was doing the same thing. The blower fan was also cutting off intermittently as well. Turned out the TIPM was fucked. Took it to the dealer and they replaced it. Haven't had a problem with either the lights or the blower since.I had purchased the extended warranty when I bought the Jeep. That shit has more than paid for itself many times over. :koolaid2:
 

·
Registered
Joined
·
37 Posts
I've had this same problem with my 08 for over two years now. Every time it's happened I've unhooked battery cables, and went away for 4-6 months. No codes, no loose or dirty connections.
I'm thinking the computer is some how jamming up with the flash relay during the keyless unlock feature. Just because of the timing of the flashes when I try to turn my headlights on??? If I hit the keyless unlock button while I'm having this problem, my lights don't flash or turn on, BUT... they flash once when I open my door!
Or there could just be demonic spirits added as a factory freebie.
 

·
Registered
Joined
·
37 Posts
Were your HIDs flickering, or flashing? This problem we have going on is the headlights only are going out, and they will come on for a split second, go out for 5 seconds, and flash again. They will do this 3 to 5 times and then stay off.
The timing of them going out is a consistent rhythm of flashes before going out completely.
I was wondering if going to HIDs would "fix/bypass" this problem? And I'm always looking for a good reason to upgrade!
 

·
Registered
Joined
·
123 Posts
Were your HIDs flickering, or flashing? This problem we have going on is the headlights only are going out, and they will come on for a split second, go out for 5 seconds, and flash again. They will do this 3 to 5 times and then stay off.
The timing of them going out is a consistent rhythm of flashes before going out completely.
I was wondering if going to HIDs would "fix/bypass" this problem? And I'm always looking for a good reason to upgrade!
I have a buddy that has this issue. He has tried HID, Trucklites and JW speakers and sill has the issue.
 

·
Registered
Joined
·
292 Posts
I think its my connection or the TIPm cuz i did the error connector and still flashed. Or its a connection. I was told also to check my grounds and they where going right to frame. I want to try it again. But its kinda a pain in the ass.


Sent from AutoGuide.com App
 

·
Registered
Joined
·
279 Posts
It's almost exactly one year from when this happened and the ghosts are back. I've got HID lights in now but have had them in for over 9 months, problem was there with stock bulbs and with these. TIPM looks like the culprit.
 

·
Registered
Joined
·
12 Posts
Hi all first post been having similar issues i have HID I get them to work by messing with the in line fuse wondering if it's a switch signal issue some of us are experiencing
 

·
Registered
Joined
·
279 Posts
I did a little research the first time it happened and the JK doesn't have a fuse for the stock lights, they run off of a switch/chip thing in the TIPM which sucks for us.
Glad the aftermarket lights have in inline fuse that fixed your problem.
 

·
Registered
Joined
·
1,884 Posts
I did a little research the first time it happened and the JK doesn't have a fuse for the stock lights, they run off of a switch/chip thing in the TIPM which sucks for us.
Glad the aftermarket lights have in inline fuse that fixed your problem.
You are correct.
These are what act as fuses and switches, including the pulse width modulation switching.

 

·
Registered
Joined
·
1 Posts
Hi All,

First post here. I am having the same problem with my 2008 Unlimited Rubicon (lights frequently & even the blower fan went out once). Based on this thread it looks like the TIPM might be to blame.

For those who had this problem, did you resolve it by replacing the TIPM?

Thanks,
Brian
 

·
Registered
Joined
·
1 Posts
Got the same problem with left fog light. PO had non working HID fog lights. I took them out and put stock back in. Worked for about 6 months. Now flashes a few times when turning on. Curiously, all lights work fine if the engine is off.
 
21 - 40 of 49 Posts
Top