JKOwners Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
90 Posts
Discussion Starter #1
I have a weird issue with my 2014 rubi that I just lifted.

Now, this is not my first rodeo when it comes to lifting a vehicle. I've done several jeeps, including other JK's, but this is the first time I've seen this issue.

I put a 2.5" lift and 35's on my 2 door 6 speed about a week ago. I was going to get a AEV procal for my TPMS and to correct my MPH and milage.

Well I got to noticing that my GPS is dead on with my MPH hand? How can that be? My last Jk was a 09 JKUR auto and I had to use a procal to get my milage and speed corrected? How is my 14 6 speed different?

Any of you seen similar circumstances? Am I missing some change to the newer Jeeps that you don't have to correct the MPH after adding larger tires?
 

·
Registered
Joined
·
371 Posts
I had to change mine with 2014 2dr 6 speed after going to 35" tires and 3.5" lift. the lift doesnt change the speedometer its the tire size and rotation of it.. That's weird..
 

·
Registered
Joined
·
90 Posts
Discussion Starter #5
Now I'm thinking I'm not going to waist the money on a procal just to fix my TPMS light.
 

·
Registered
Joined
·
388 Posts
i should probably know this, but I don't... how does the JK calculate the speed that shows up on the speedometer?

did you do a regear, and if so, is it possible that the new gears compared to the new tire circumference is identical to the old gear/tire combo so the MPH still reads correctly?
 

·
Registered
Joined
·
21 Posts
Are you talking about the GPS in the factory navigation? I believe that speed reading is driven by the speedo on the dash. So they match but are both incorrect.
 

·
Registered
Joined
·
90 Posts
Discussion Starter #8
No regear. The jeeps drivetrain is stock.

I also thought all GPS navigation units had the signal coming from satilight? The mph on the nav should be different from my speedo since I'm running 35's with stock gears in the diffs.
 

·
Registered
Joined
·
90 Posts
Discussion Starter #9
Rowbarre
How sure are you that the nav unit uses the mph reading from the jeep?

I'm going to put my TomTom in the jeep tomorrow and compare the two. I'll update y'all so at least we'll know how they work.
 

·
Registered
Joined
·
1,196 Posts
Rowbarre
How sure are you that the nav unit uses the mph reading from the jeep?

I'm going to put my TomTom in the jeep tomorrow and compare the two. I'll update y'all so at least we'll know how they work.
my buddies did. he kept saying his speedo was spot on after 35's according to his 430N. He compared it to my phone app speedo and my garmin and his was off.
 

·
Premium Member
Joined
·
95 Posts
I'm 5mph off in 6th on 35's. 60mph is 65mph according to gps via the WAZE app.
 
1 - 13 of 13 Posts
Top