JKOwners Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I've searched and read numerous forums related to my issue, but it seems like nobody can pin point the exact problem. My jeep goes into limp mode quite often, and turning it off and back on will occasionally fix it. The etc and traction light comes on. It throws a lot of codes, cam position sensors, throttle pedal, low barometric pressure, erratic voltage, among many others. I've tried basics, took it to multiple local guys, all to no avail. All I can think is a possible bad ecm. I wanna avoid a dealership at all costs. Had anyone tried flagship 1 for an ecm. Seems like most people have had bad experiences. Anywhere else to get a reliable ecm? Or any suggestions as to a fix? By the way, it's a 2012 2 dr sport, 3.6 manual trans. Thanks for any help
 

·
Registered
Joined
·
521 Posts
I had this exact problem about 1 year ago. One of my ECU lock levers was partially unlatched. Like, so little that I couldn't tell by looking at it. I unlocked both levers, looked at the pins and made sure everything was ok (no burns, corrosion, etc). Ratcheted the levers back down and never had the issue again.
 

·
Super Moderator
Joined
·
6,175 Posts
I've searched and read numerous forums related to my issue, but it seems like nobody can pin point the exact problem. My jeep goes into limp mode quite often, and turning it off and back on will occasionally fix it. The etc and traction light comes on. It throws a lot of codes, cam position sensors, throttle pedal, low barometric pressure, erratic voltage, among many others. I've tried basics, took it to multiple local guys, all to no avail. All I can think is a possible bad ecm. I wanna avoid a dealership at all costs. Had anyone tried flagship 1 for an ecm. Seems like most people have had bad experiences. Anywhere else to get a reliable ecm? Or any suggestions as to a fix? By the way, it's a 2012 2 dr sport, 3.6 manual trans. Thanks for any help



I would bet $20.00 that this is electrical. It is 9 times out of 10 an electrical issue on JKs.

Even tho you disagree, OP, check charge & all grounds to everything. It might be a bad TIPM but start w your grounds and battery charge first.
Your issues are too erroneous & "all over " & that "erratic voltage" PID error code is partially revealing....

Get your multimeter out & report back....

 

·
Registered
Joined
·
63 Posts
I've searched and read numerous forums related to my issue, but it seems like nobody can pin point the exact problem. My jeep goes into limp mode quite often, and turning it off and back on will occasionally fix it. The etc and traction light comes on. It throws a lot of codes, cam position sensors, throttle pedal, low barometric pressure, erratic voltage, among many others. I've tried basics, took it to multiple local guys, all to no avail. All I can think is a possible bad ecm. I wanna avoid a dealership at all costs. Had anyone tried flagship 1 for an ecm. Seems like most people have had bad experiences. Anywhere else to get a reliable ecm? Or any suggestions as to a fix? By the way, it's a 2012 2 dr sport, 3.6 manual trans. Thanks for any help

Whats your reason for not wanting to get it fixed at the dealer?
 
1 - 4 of 4 Posts
Top