JKOwners Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
114 Posts
Discussion Starter #1
I installed a set of these, they are nice but im having a problem with a wire. they come with a small led bulb that should turn on when the parking lites are on. does anyone have a set of these? where did you connect the one white wire with red dots too? this powers the small led bulbs.
 

·
Registered
Joined
·
777 Posts
mine are spliced in to the turn signal bulbs on the passenger side front flare

trace the wire through and tap into it where ever you can

hope that makes sense


have had it like that for 2+ years and no issues
 

·
Registered
Joined
·
114 Posts
Discussion Starter #3
no i just bought the jeep used a couple months ago, i just installed them. i ended up figuring it out, thanks.
 

·
Registered
Joined
·
99 Posts
I guy with an F150 did a very good install thread on these. Google search PIAA 525 and you should find it on one of the... nevermind just found it

http://www.f150online.com/forums/appearance-products/355947-piaa-525-install-pics.html

He ran it right to the battery. I've run a few PIAA harnesses and I always run them into an accessory slot in the fuse box. With the 525s it may require you to run two. There are a few open slots in the fuse box. A few are on only when the key is turned to accessory and a few are always on. I would run the fog/driving beams to an always on and the blue LED to a keyed slot, that way you don’t accidentally leave the LED on.
 
1 - 4 of 4 Posts
Top