JKOwners Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter #1
Hey everyone, trying to figure out how to get a pentastar fan working in my 07. I have hp tuners and I see the option for a pwm fan. I also know about the need for upgraded power delivery. But I'm not sure on the exciter wire and where it would come from? Anybody have the info and would like to share?
 

·
Registered
Joined
·
18 Posts
Subscribed. This would make a pretty awesome write up if you can make it work with the 3.8. Probably not useful to you, but I can tell you in my ls swap in my 08, I'm using the pentstar fan. The pwm control wire runs directly to the gm ecu and power goes directly to the battery with an inline fuse.
-Chris



Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
1,019 Posts
So as you noted, you need to run its own set of power and ground wires with a self resetting breaker on the hot side or a fuse or whatever you want. As far as the signal wire you need pull out the TIPM and find the connector C3. Look for a brown wire with a light blue stripe on it. It will be in position #2 on that connector. Cut that wire far enough out from the connector to allow you to slice another wire onto it and splice in the small gauge green wire from the fan.

Beyond that I HAVE NO CLUE if you need any special programming other than what you are seeing in your HPT program. This is just the instructions for the hardware side of it.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #4
So as you noted, you need to run its own set of power and ground wires with a self resetting breaker on the hot side or a fuse or whatever you want. As far as the signal wire you need pull out the TIPM and find the connector C3. Look for a brown wire with a light blue stripe on it. It will be in position #2 on that connector. Cut that wire far enough out from the connector to allow you to slice another wire onto it and splice in the small gauge green wire from the fan.

Beyond that I HAVE NO CLUE if you need any special programming other than what you are seeing in your HPT program. This is just the instructions for the hardware side of it.
great thx for the info that's what I was looking for. I've been reading I might need to reprogram the Tipm.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #5
Subscribed. This would make a pretty awesome write up if you can make it work with the 3.8. Probably not useful to you, but I can tell you in my ls swap in my 08, I'm using the pentstar fan. The pwm control wire runs directly to the gm ecu and power goes directly to the battery with an inline fuse.
-Christie



Sent from my iPad using Tapatalk
thanks for the reply, I'm also ls swaped but I need the Jeep side to control ac fan speed or else that would be perfect.
 

·
Registered
Joined
·
645 Posts
So as you noted, you need to run its own set of power and ground wires with a self resetting breaker on the hot side or a fuse or whatever you want. As far as the signal wire you need pull out the TIPM and find the connector C3. Look for a brown wire with a light blue stripe on it. It will be in position #2 on that connector. Cut that wire far enough out from the connector to allow you to slice another wire onto it and splice in the small gauge green wire from the fan.

Beyond that I HAVE NO CLUE if you need any special programming other than what you are seeing in your HPT program. This is just the instructions for the hardware side of it.
Takes a special program uploaded to the TIPM to get the Pentastar fan to run. I plugged in a brand new TIPM and my fan would not run at all. You can send your TIPM to Robbie @MoTech or Jon @rpmextreme to have it flashed.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #7
So as you noted, you need to run its own set of power and ground wires with a self resetting breaker on the hot side or a fuse or whatever you want. As far as the signal wire you need pull out the TIPM and find the connector C3. Look for a brown wire with a light blue stripe on it. It will be in position #2 on that connector. Cut that wire far enough out from the connector to allow you to slice another wire onto it and splice in the small gauge green wire from the fan.

Beyond that I HAVE NO CLUE if you need any special programming other than what you are seeing in your HPT program. This is just the instructions for the hardware side of it.
Takes a special program uploaded to the TIPM to get the Pentastar fan to run. I plugged in a brand new TIPM and my fan would not run at all. You can send your TIPM to Robbie @MoTech or Jon @rpmextreme to have it flashed.
thx for the reply, yea that's what I thought. Yea I've been dealing with rpm for parts so I'll send Jon a message.
 

·
Registered
Joined
·
520 Posts
07 TIPM will not run a Pentastar fan. Does not have the ability to program for it.

I just installed one on my 07. Best bet would be to contact Jon at RPMExtreme and see what options you have. May be able to run his EzCanus to control the fan. I have an LS conversion with his EzCanbus and that is what he reprogrammed and I hooked up to, to run the fan. Works great
 
  • Like
Reactions: rockystock

·
Premium Member
Joined
·
528 Posts
Thanks! I found that AEV has a solution as well. Not sure which way to go yet but I do have the C&R radiator that's set up for the 3.8 (and maybe 3.6?) fan to bolt on.

https://secure.aev-conversions.com/shop/3-6l-jk-fan-conversion-harness
07 TIPM will not run a Pentastar fan. Does not have the ability to program for it.

I just installed one on my 07. Best bet would be to contact Jon at RPMExtreme and see what options you have. May be able to run his EzCanus to control the fan. I have an LS conversion with his EzCanbus and that is what he reprogrammed and I hooked up to, to run the fan. Works great
 

·
Registered
Joined
·
520 Posts
Thanks! I found that AEV has a solution as well. Not sure which way to go yet but I do have the C&R radiator that's set up for the 3.8 (and maybe 3.6?) fan to bolt on.

https://secure.aev-conversions.com/shop/3-6l-jk-fan-conversion-harness
If you are wondering about the fans (3.8 and 3.6) installing either will fit. They mount the same and in the same locations.

Just looked at the link. It states in there that you have to replace your tipm with a new 2009 model tipm have it programmed or a used one and use their programmer. That is all on top of the $65 purchase of their wiring harness.

You may already see that but just a heads up.
 
1 - 15 of 15 Posts
Top