JKOwners Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
107 Posts
Discussion Starter #1
Help Engine would not start this morning Starter clicking and dash lights going on and off. Battery seams to be ok. Also tried it in Natural still nothing. Turn switch to on and all light go off except the engine symbol. Had tocome to work didnt have time to work on it. I found a service bulletin on the WCM will try what it said to if it is the WCM. Could this be related to Superchips flashpac? Anyone have this fixed, is it a DIY or dealer fix and how much did it cost.
 

·
Registered
Joined
·
3,887 Posts
"Battery seems ok"- that means nothing. You need to put a meter on there and see what the voltage is. I discovered last week that it won't start if the voltage is below 13v. But that is still plenty to run everything else, just won't turn the starter and all you get is a "click"
 

·
Registered
Joined
·
107 Posts
Discussion Starter #3
Didnt have time to get a meter out this morning. I will check it when I get home. I did turn on 130 Watt lights and they did not dim at all when I tryed the starter. Thanks
 

·
Registered
Joined
·
184 Posts
I would bet it is your battery. I had to replace my battery last week. If it will start with just a jump, go replace the battery. My voltage was at 12.5 vdc before starting and the multimeter did not drop below 11 vdc during start. Also, my engine light was on.
 

·
Registered
Joined
·
3,887 Posts
Yeah- My original battery bit the dust last week. Ordered an Optima yellowtop $176 delivered :D Battery came in yesterday... Unfortunately my Jeep is in RockRash's shop this week. So I have a battery but no Jeep to put it in :bawling:
 

·
Registered
Joined
·
107 Posts
Discussion Starter #9
Thank,s everyone, It turn out to be the battery. I hooked the super chips up to it and ran the diagnostic tool and it can up battery low voltage. Looks like a new Battery. Again Thanks for the help!!!:beer::beer:
 
1 - 9 of 9 Posts
Top