JKOwners Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
41 Posts
Discussion Starter #1
Hi guys,

I have a RHD 2008 JK fitted with a completely rebuilt 5.7 Hemi, a 545RFE and a JSS Hemi Kit.
The conversion was done last winter by a Pro from West Yorkshire as I live in the UK. I picked up the Jeep in January and it worked fine for few months.

Until around spring time this year when I was enjoying the huge Torque of that engine when taking over on the Motorway at around 75mph. All of a sudden it stopped pulling and went high in Revs as if the Transmission went into Neutral but it wasn't. So I released the accelerator and the Jeep started pulling again but soon after I realised the max speed I could go was about 60mph instead of the usual 85/90mph at same Revs when all was good.

I gradually noticed that the Transmission works but with lazy/late shifting but goes into every gear up to the 5th if I stay light on the accelerator but as soon as I want to take over or give it a bit of Revs the Trans goes down from 5th to 4th gear and never goes back to 5th anymore unless I stop and restart.

So after lots of online search I replaced the Transmission Solenoid pack as I heard that this part needs to be replaced when that Transmission gets around 70/80K Miles. Since I bought it second hand I thought that would cure the issue but it didn't.

I emailed Todd from JSS and he told me that my Transmission is old and I need to replace the Valve Body. The thing is if that was the case this issue would have occurred from day one but it has worked fine for about 4 months.

So I took the Jeep to an Auto-Trans Specialist. He kept the Jeep for a week, carried out all sorts of Tests and finally told me that there is nothing wrong with the Transmission. He said there is a Fault code: C121C "Torque Request Denied". He said the 5th gear in the 545RFE Transmission is only controlled by the ECU and until this fault is cleared the ECU will not send the command to go into 5th gear.

According to the Service Manual that fault is due to a break in the link between the ECU and the ABS.

I am struggling to find a good Auto Electrician this side of the Atlantic so I thought I would post my problem on here just in case this Fault has happened to someone else.
 

·
Registered
Joined
·
1,783 Posts
DTCs P0344, C121C and ESP light
P0390 & c121c - Jeep Wrangler Forum
A quick search found 2. Correlation does not equal causation.
It could be a common ground, weak battery or connection, harness connector, abs, crank sensor (or was it cam sensor?)
One guy replaced his sparkplugs and wires which fixed it.
Good luck. Let us know what it was.
 

·
Registered
Joined
·
41 Posts
Discussion Starter #3
Hi Coilrod,

Thanks for your input. I read these two posts a while back but there are things mentioned in these that I have experienced already.
A couple of months ago I had the code P0344 and I replaced the Camshaft sensor which cleared that fault.
I could replace the Spark Plugs but the Hemi Spark Plugs are fitted to Coil packs directly connected to the complete wire Harness which came with my Hemi Kit from JSS and is only few months old. I know it's not because parts are new that they are not faulty but it has worked fine for few months.

I have a Dual Battery system with 2 x Odissey batteries so I don't think that comes from there either. I must find a decent Electrician to help me.

I will post back on here if I get it sorted.
 

·
Comfortably Numb
Joined
·
12,289 Posts
Hello and welcome to JKO. I remember a situation with a member on here that is somewhat close to yours. Don't know if this will help but he had electrical leakage in his spark plug wires which at a certain rpm would arc to ground and cause a similar situation to yours. If you have any kind of electrical leakage you can check it by starting your engine and looking at your sparking plug wiring or coils in darkness as you rev your engine. Also check your batteries for voltage under load. By the way I have relatives from my dad's side of the family in Bexleyheath Kent.
 

·
Registered
Joined
·
41 Posts
Discussion Starter #5
Hello RubiCajun,

Thanks for your post. It is an interesting Test that I am going to try to carry out ASAP.
Bexleyheath is only 1 hour drive from me. I wish I could live in Louisiana like you though.
 
1 - 6 of 6 Posts
Top