JKOwners Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
:gluging:Hello All! First off i wanted to say I'm new to the forum and this is my first post but i have been thoroughly impressed with the community on this forum. I was hoping some of you pro's out there can help me out! I have a 2010 2dr Rubicon and I noticed that when turning left about 3/4 turn and in motion i get a squeaking noise accompanied with a vibration in the steering wheel. It's not a clunking noise it's more of a whining/skipping as if something was not gripping properly or struggling to keep itself in that position.:shitstorm:

.
It's a lot more prominent when holding a left turn and moving, but motionless it has no noise at all. I tried to self diagnose and i noticed one of the lower controls arms was EXTREMELY loose (to the point the nut holding it on was only threaded half-way on the end of the bolt!) I tightened it up and now the squeaking/skipping noise happens less often but none the less it still happens and only while moving and making a left turn with the wheel about 3/4 of the way. It appears to only happen around 5-15 mph (maybe because i don't take turns faster than that lol) It almost seems like it happens if im turning and the weight shifts then i can feel it.


I do have a Teraflex 2.5" coil lift and am running 35's. I was thinking maybe lube the bushings with some lithium grease or something similar but this has really got me scratching my head. I'm hoping one of you guys out there has some suggestions for this. If you know anything It would be appreciated.
:gluging:

:thankyou:
 

·
Registered
Joined
·
3,349 Posts
Dust shield on your axle...remove it or replace it.

:gluging:Hello All! First off i wanted to say I'm new to the forum and this is my first post but i have been thoroughly impressed with the community on this forum. I was hoping some of you pro's out there can help me out! I have a 2010 2dr Rubicon and I noticed that when turning left about 3/4 turn and in motion i get a squeaking noise accompanied with a vibration in the steering wheel. It's not a clunking noise it's more of a whining/skipping as if something was not gripping properly or struggling to keep itself in that position.:shitstorm:

.
It's a lot more prominent when holding a left turn and moving, but motionless it has no noise at all. I tried to self diagnose and i noticed one of the lower controls arms was EXTREMELY loose (to the point the nut holding it on was only threaded half-way on the end of the bolt!) I tightened it up and now the squeaking/skipping noise happens less often but none the less it still happens and only while moving and making a left turn with the wheel about 3/4 of the way. It appears to only happen around 5-15 mph (maybe because i don't take turns faster than that lol) It almost seems like it happens if im turning and the weight shifts then i can feel it.


I do have a Teraflex 2.5" coil lift and am running 35's. I was thinking maybe lube the bushings with some lithium grease or something similar but this has really got me scratching my head. I'm hoping one of you guys out there has some suggestions for this. If you know anything It would be appreciated.
:gluging:

:thankyou:
 
1 - 7 of 7 Posts
Top