JKOwners Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
166 Posts
Discussion Starter #1
Hi,

I have a set of the Mopar led headlights in my 2008 JKUR. Those headlights are running fine in normal driving conditions. But when I turn off the key and the 'follow me' function is active (for 30 seconds), then they start flickering. I also can hear some kind of buzzing noise then, which is not there, when the led lights work normal.
I did not install any anti flicker harness as I was told from the dealer, that those Mopar led headlights don´t need it.
Does anybody have an idea, what could be the reason for this behavior and how to get rid of it ?

Thanks in advance for your answer.
 

·
Registered
Joined
·
103 Posts
I'm not familiar with this problem, but my first suggestion would be to check your battery voltage after turning the key off and with the headlights on.

It sounds to me like the headlights are getting plenty of voltage with the key on and/or engine running, then the voltage is dropping out once the key is turned off. It may be time for a new battery, or maybe just a good cleaning of battery terminals and cable lugs is in order.
 

·
Super Moderator
Joined
·
6,181 Posts
I don't know much about this particular set of headlamps from Mopar (via JWSpeaker) so pardon me if I ask a pooible stupid question ;

How come on every source I check for info pertaining to these , it states they are for 2011-2017 (first version) or 2014_2017 (second version)Jeep Wrangler and Wrangler Unlimited ?

Just curious ,not insinuating that because yours is an '08 that that is the issue . I just could not locate the same lights for a 2007-2010 JK or JKU ..:jeep2:
 

·
Registered
Joined
·
166 Posts
Discussion Starter #5
Hello,

I'm having the same issue. Did you figure it out by any chance?
No, not yet.

I'm not familiar with this problem, but my first suggestion would be to check your battery voltage after turning the key off and with the headlights on.

It sounds to me like the headlights are getting plenty of voltage with the key on and/or engine running, then the voltage is dropping out once the key is turned off. It may be time for a new battery, or maybe just a good cleaning of battery terminals and cable lugs is in order.
Battery is about 6 month old. So I was assuming, that the battery voltage is not the problem. But maybe I should check this :). When the headlights flicker, there is also some noise. When they are not flickering, it is silent.

I don't know much about this particular set of headlamps from Mopar (via JWSpeaker) so pardon me if I ask a pooible stupid question ;

How come on every source I check for info pertaining to these , it states they are for 2011-2017 (first version) or 2014_2017 (second version)Jeep Wrangler and Wrangler Unlimited ?

Just curious ,not insinuating that because yours is an '08 that that is the issue . I just could not locate the same lights for a 2007-2010 JK or JKU ..:jeep2:
Infact I put the 2011 - 2017 in my 08. I did not see any reason, why this should not work.
 

·
Super Moderator
Joined
·
6,181 Posts
al lis good. Again, just trying to find out why those are listed as only for the '11s or 13s and up.
Did you have your JK ECU flashed at dealership after installing and it was alright ?

Take a read of this if you haven't already and maybe that can get you some info that may help.
Sounds like a ground issue from the described behavior you're experiencing.

( I will also point out I am not an expert on this, just curious. I run Delta H4 conversion halogen lights in my JKUr with Hella stupid bright bulbs on a RallyLights harness. Thought I should make that clear)

:jeep2:
 

·
Registered
Joined
·
166 Posts
Discussion Starter #7
al lis good. Again, just trying to find out why those are listed as only for the '11s or 13s and up.
Did you have your JK ECU flashed at dealership after installing and it was alright ?

Take a read of this if you haven't already and maybe that can get you some info that may help.
Sounds like a ground issue from the described behavior you're experiencing.

( I will also point out I am not an expert on this, just curious. I run Delta H4 conversion halogen lights in my JKUr with Hella stupid bright bulbs on a RallyLights harness. Thought I should make that clear)

:jeep2:
Thanks for the link. It is quite interesting. I did not have my ECU flashed. Infact, I don´t like it to be flashed, as I have a hemi engine. I also do not have the problem, that the lights are brighter, when engine is off. This is all fine for me.

I will get the ground connection checked.
 
1 - 7 of 7 Posts
Top