JKOwners Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
351 Posts
I am in. Send me pics. Have office in San Diego and can come get it.
 

·
Registered
Joined
·
532 Posts
:shocked::shocked::shocked::shocked::shocked::shocked: nice bumper, would love to have it... but alas no money. good luck with the sell
 

·
Registered
Joined
·
351 Posts
Responded to your PM before i saw you posted pics here. No need to send to my email. These pics were good. Thanks for posting them. This is not going to work for me though. Good luck!
 

·
Registered
Joined
·
174 Posts
Doesnt look like it was mounted correctly; the tire carrier should be against the rubber bumpers. Unless you bent that sh&^
 

·
Registered
Joined
·
101 Posts
Discussion Starter #13
Doesnt look like it was mounted correctly; the tire carrier should be against the rubber bumpers. Unless you bent that sh&^
It's installed correct and it is not bent.. are you kidding me?? how do you even do that with 35's. it will only make contact with the rubber bumpers if you have the L brackets installed off the tire carrier. I'm not sure if you know much about the LOD bumpers or not, but it can't be mounted close enough to the body to be able to touch the bumpers without additional brackets. :thefinger:
 

·
Registered
Joined
·
101 Posts
Discussion Starter #15
What u need to do is, loosen up all the bolts, put a bottle jack under the hitch, lift it up and tighten the bolts back up. I had the same problem
Thanks for the info, but I'm actually just going to be pulling this off when I get a buyer. Also, it might be just the angle of the pic, but this bumper is not bent or leaning.
 

·
Registered
Joined
·
174 Posts
I see now you dont have the L brackets installed; my bad!
 
1 - 17 of 17 Posts
Top