JKOwners Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hey all! New Jeep owner here. I purchased a 2012 Wrangler Unlimited. My left front turn signal is not working. When I turn on my left turn signal, it is showing on the dash, it starts out blinking normal, but after a few seconds it goes to rapid flash. The rear left turn signal works fine, as does all on the right side. I have replaced the bulb, but still nothing. Headlights work fine. Which step should I take next?
Thanks!
 

·
Registered
Joined
·
39 Posts
Might check the wiring connections. See if a wire is cut or frayed. Those wires ride a bit loose (near the lights) and with enough vibration can start to wiggle loose. I have even seen the bracket connecting them break.
 

·
you can go piss up a rope
Joined
·
1,319 Posts
Are any of them LEDs?
Also, it might make sense to try swapping between the left and right fixture to see if the issue persists or follows the bulb.
Previously, it's been mentioned that the fixtures can get oxidized / dirty and cause issues.
 

·
Premium Member
Joined
·
84 Posts
Check the ground for that light.


Sent from my iPhone using Tapatalk Pro
 

·
Super Moderator
Joined
·
6,292 Posts
put plastic safe , dielectric grease within pin seats of the connector once you secure it anew. Not having good ground somewhere will cause these to intermit go to fast blink ...so can a short or improperly loaded ( too much or too little due to poorly resistorered or grounded LEDs ( or other aux power tapped add-on ) somewhere in the run of the harness.

if it makes OP feel better , I have LEDs everywhere EXCEPT my front turn indicators . I blow the left ( pssgr) front turn to fast blink all the time due to the 4way LED taillight I run - although its properly resisted - allows some hard to troubleshoot, current irregularities to sometimes takeout the fuse for that pssgr side turn signal if I use it many times in a row. I just carry lots of 15amp minifuses .
 

·
Registered
Joined
·
3 Posts
My rear tail light plug was causing the same issue and I decided to try upgrading my rear tail lights. It worked and I got a better look.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
597 Posts
It could be low on blinker fluid.
Sorry, it HAD to be said. 🤣. I couldn’t resist.
 

·
Registered
Joined
·
2 Posts
Hey all! New Jeep owner here. I purchased a 2012 Wrangler Unlimited. My left front turn signal is not working. When I turn on my left turn signal, it is showing on the dash, it starts out blinking normal, but after a few seconds it goes to rapid flash. The rear left turn signal works fine, as does all on the right side. I have replaced the bulb, but still nothing. Headlights work fine. Which step should I take next?
Thanks!
I would check the ground on the turn signal, even the bulb and socket, Sounds like water has got in there...seen it before. Might get lucky and just need a bulb...

Toad
 
1 - 8 of 8 Posts
Top