JKOwners Forum banner

1 - 20 of 26 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Long story short, I ended up installing 2018 Sahara JL axles on my 2016 Sport JKU.

JL axles are a bit wider, given I've got adjustable control arms, track bars, the geometry is pretty much spot on. However I ran into a few issues:

- Rear JL axle shock mounting brackets needed to be angle-adjusted, since JL shocks are mounted onto the inside of the frame. Easy fix - cut ant weld the brackets back on.
- Rear diff drive shaft flange is slightly different, but Adams Driveshafts made me a set of driveshafts that work perfectly, I needed new ones anyway.

- Now is a more complex issue and I hope people can help me to figure it out. It seems that JL wheel speed sensors work differently, because I get almost double speed shown on the dashboard, i.e. 40mph instead of 20mph. I did count the number of tone ring teeth which seems to be 52, same as JK. I did program correct axle gear ratio, tire size, etc.

Wrong speed measurement is annoying, but what's more annoying is the fact that my traction control is playing up, it tends to kick in hard when I am making turns at slow speeds. The light flashes and brakes are kicking in. No error codes are shown that the wheel speed sensors are bad or malfunctioning.

So I am puzzled here. I do have a way to debug the hell out of my jeep, so any tips and help is much appreciated.
 

·
Registered
Joined
·
243 Posts
No help debugging, but I wonder if you can somehow just program for a 16" tire? Or half of whatever your size is.

Sent from my SM-G973U using Tapatalk
 

·
Registered
Joined
·
1,559 Posts
Interested in the outcome. I see those Rubi JL axles come on the market every so often. I thought the swap would be pretty straight forward too. I guess the mechanical side is straight forward, just not the electronic side.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #4
No help debugging, but I wonder if you can somehow just program for a 16" tire? Or half of whatever your size is.

Sent from my SM-G973U using Tapatalk
I set the tire size to 16" (actual size is 32.2"). I think the speed is pretty close to reality now and traction control issue is greatly improved. What's interesting is that traction control seems to only kick in when I am in Drive and turning to the left or right while driving slowly (10mph or more).
 

·
Registered
Joined
·
104 Posts
I set the tire size to 16" (actual size is 32.2"). I think the speed is pretty close to reality now and traction control issue is greatly improved. What's interesting is that traction control seems to only kick in when I am in Drive and turning to the left or right while driving slowly (10mph or more).
Pretty sure this happens because the ESP / Traction control is looking at the difference in all 4 wheel speeds and freaks out because it thinks you're sliding or spinning wheels going around the corner.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #7
Pretty sure this happens because the ESP / Traction control is looking at the difference in all 4 wheel speeds and freaks out because it thinks you're sliding or spinning wheels going around the corner.
That's the most likely cause. Could it be because one or more wheel speed sensors are bad or partly bad? When I was mounting the JL axles, I noticed that one speed sensor had a bad wire (looked it was toasted, maybe touched the exhaust or something hot), I fixed the wire and had no DTC codes.

Is it possible that the Jeep is not showing error codes and yet one of the wheel sensors is misbehaving?
 

·
Registered
Joined
·
243 Posts
I've always gotten codes if there's a wheel speed sensor connection problem on my jk.

Just watch out if only swapping 1/4, might do crazy things of the other 3 speeds don't match

Sent from my SM-G973U using Tapatalk
 

·
Registered
Joined
·
12 Posts
Discussion Starter #11
I think if you only swap one and the JK sensor does in fact read differently than a JL one, you are going to send the traction control system into a shit storm.
Haha. It's close to a shit storm right now. I have to run 16" tire size setting for the speedo measurement to be close to normal and yet traction control is behaving funny when turning.

The plan is to swap a single JL speed sensor for a JK one, then read individual wheel speeds with a debugger and see if the wheel with JK sensor is reporting 1/2 the speed the JL ones do.
 

·
Banned
Joined
·
514 Posts
You probably damaged a sensor during the swap. I found out the hard way how delicate they are. Code scan should show you which one is faulty, replace it/them and go from there? I thought the jl knuckles sounded weak as they are aluminum?
 

·
Registered
Joined
·
1,559 Posts
Aluminum yes, but thicker than the sheet metal they gave the JK. I like the width the Rubicon axles come in. Also, cheap way to get locker and 4.10’s for 35’s. Damn regear is close to $2,000 in NE Texas and whatever for the lockers.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
12 Posts
Discussion Starter #14
You probably damaged a sensor during the swap. I found out the hard way how delicate they are. Code scan should show you which one is faulty, replace it/them and go from there? I thought the jl knuckles sounded weak as they are aluminum?
Sensor wires got damaged or they were already damaged when I bought the axles, so soldered the wires back together. That's the thing, code scan does not bring up any issues with sensors. All 4 wheels are sensing the speed.

What I am not 100% sure is whether it is possible for the scanner not to detect an issue with a semi-faulty sensor.
 

·
Registered
Joined
·
1,359 Posts
I read in one of the one-ton threads a long time ago where another Jeeper took all of the sensor wires and connected them to a single wheel sensor. It made the speedo work fine, but eliminated all of the different signals, effectively disabling the traction and stability control.

not sure it's an option for you, but I thought I'd mention it.
 

·
Super Moderator
Joined
·
6,209 Posts

I ,also, tried to rustle up that thread Guruman refers to; wasn't where we learned that the JK/JKU really only needs a single WSS to be wired in that manner ,allowing it to suffice & appease the slip-mitigation gods?

I could be imagining that but don't think so...
 

·
Registered
Joined
·
12 Posts
Discussion Starter #18
Some updates on my journey. Apparently 2012+ year JK transmission take rear wheel speed sensors into the account, so given my JL axles speed sensors are reporting 2x actual speed, JK system is freaking out - grearbox is in limp mode, etc.

Even though I managed to get correct speed and odometer readings by setting 1/2 the actual tire size, that does not really help when it comes to the rest of the system.

OK, so that's a big issue. My next step is to try installing a JK wheel speed sensor and monitor speed readings of that wheel. I hope that JK sensors will fit into JL wheel bearing assembly. I'll keep you posted.

Again, your ideas and suggestions are more than welcome. Thanks.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #19
Just had an idea before I get time to actually go and swap the sensors.

From my preliminary testing of the JL sensors, they are sensing 2x the actual speed. Which is for every tone ring tooth, the JL sensor is sending 2 pulses instead of 1. So I come up with this formula, which could potentially trick the system that everything is fine:

tone ring tooth count / 2 X tone ring tooth count X gear ratio

52/104*3.73 = 1.865 axle gear ratio

Tire size would have to be sliced in half too.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #20 (Edited)
So I have some good news.

I swapped the front wheel speed sensor, used the JK one, which fits right in perfectly. The JL one has a green rubber ring.




Then I went on to check whether the wheel with JK sensor in, is reporting half the speed compared to the other wheels. BINGO - it does.




I had a spare JK rear wheel sensor, so tried to swap that, but apparently JL and JK rear wheel sensors are quite different, JK one is a lot bigger. But I figured it wouldn't be so hard to make the hole that the sensor is pushed through a bit bigger, since the rear wheel sensors are exposed anyway, unlike the front ones.

Here are some pictures how the look and where they mount into the axle.









I just ordered 4 new JK sensors and I will install them. I think this is going to be it. It makes total sense now why my traction control and transmission was going mental. Will keep you posted.
 
1 - 20 of 26 Posts
Top