JKOwners Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1 (Edited)
My 07 JK drops in RPM's and sort of shakes but not bad at a idle. It doesnt happen very often. My JK has 18k miles and has had a recent oil change. I just got it while i was deployed to Afghanistan so ive only drove it 800 miles since ive had it back in May. Have no idea if previous owner has done tune-up or anything. Jeep hasnt been abused there are no scraps or dings, rust or even a slight hint of mud. Dont think it was due to anbuse but maybe it needs new spark plugs?. Also there is no noises associated when the RPM's drop just the slight shudder of the engine. I fix it by reving the RPM a couple of times and it goes away. Any ideas.
 

·
Registered
Joined
·
997 Posts
Mine does this only on start up after it cooled down for a while. After a few seconds it drops down to idle RPM range (500-800 RPM) and idles like a church mouse after.

-Dan
 

·
Registered
Joined
·
19 Posts
Discussion Starter #3
Yeah mine will do it after an hour or so of driving. Ive never noticed it on startup
 

·
Registered
Joined
·
13,230 Posts
Mine does it as well at 44k. I notice the torque at idle being lower (easier to notice on a manual). I plan on cleaning the throttle body and swapping plugs, see how it does.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #5
I might do the same when i get home. Maybe some Seafoam?
 

·
Registered
Joined
·
13,230 Posts
I might do the same when i get home. Maybe some Seafoam?
With 18,000 miles I doubt plugs or carbon (what seafoam deals with) is your problem. BUT I have not seen it all!
 

·
Premium Member
Joined
·
382 Posts
Mine used to do it and I tried every type of gas treatment and seafoam through the brake booster line nothing worked until I pulled the throttle body off and cleaned it I also replaced the spark plugs and plug wires
 
1 - 7 of 7 Posts
Top