JKOwners Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
hey all , i have a 2012 jk with hot oil sway bar light flashing and dinging . trans stays in 2nd i think and speedometer dose not work. it is always on . tried disconnecting battery over night. i tried clearing codes and nothing works to resolve issue. any one know how to bypass the tipm to tcm wire issue. i heard there was a bypass that got rid of my hot oil issue. Please help i need for work. thnx in advance.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
lol , that poor jeep 0:) . My jeep has had this problem on and off for over a year. It never has had hot oil. I know it is a can bus problem , and have read some people have had rodents chew a wire causing this issue , others have had a loose battery connection (witch was my initial problem last year).After some research it looks like the dealership is running a wire bypass from the tipm to the tcm apparently this certain wire in the loom is faulty. My fluid is full. I've changed it , ive bought a new battery. It usually happens when sitting over night i will reset battery and it is fine all day even after a 300 mile drive, it runs perfect shifts perfect. There is a you tube video of a man showing how the dealership did the wire bypass but not in enough detail. I live far away from any dealership and according to others after paying for 5 or 6 visits there jeep still had the problem. If i buy a new TCM , would it have to be flashed at the dealership? Although i am still leaning towards a faulty wire harness as others had said.
 
1 - 3 of 3 Posts
Top