JKOwners Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
1,708 Posts
Discussion Starter #1
took the jeep in a few weeks ago to get a new alternator.

got it back and the horn doesnt work...

checked the fuses under the hood, both are good...

any ideas?

i dont really want to take it back to the dealership if i dont have to, even if it is there fault...
 

·
Registered
Joined
·
1,663 Posts
My horn sounds like a 1960's VW bug now after the NJ water holes.. :laughing2:

back on topic.
Does it now work at all or just very faint?
 

·
Registered
Joined
·
1,708 Posts
Discussion Starter #3
My horn sounds like a 1960's VW bug now after the NJ water holes.. :laughing2:

back on topic.
Does it now work at all or just very faint?
not working at all...

mine had the VW problem for a while... worked itself out, but now, nothing :shaking:
 

·
Registered
Joined
·
2,832 Posts
Just check the connection at the horn, mine has come loose before.

Otherwise remove the horn and clean it out, At one time wine had bunch of water in it, sounded like crap.
 

·
Registered
Joined
·
1,663 Posts
not working at all...

mine had the VW problem for a while... worked itself out, but now, nothing :shaking:
Is the relay good? Also try checking the wires just in-case one got pulled out while the alternator was being put in
 

·
Registered
Joined
·
2,073 Posts
My horn goes "ENORT"!!

:laughing::laughing2::laughing::laughing2:
 

·
Registered
Joined
·
1,663 Posts

·
Registered
Joined
·
1,708 Posts
Discussion Starter #9
Just check the connection at the horn, mine has come loose before.

Otherwise remove the horn and clean it out, At one time wine had bunch of water in it, sounded like crap.
i poked around under the hood the other day, but didnt really see where the horn is at... any help there?
 

·
Registered
Joined
·
2,073 Posts
Someone is drunk posting again :laughing2:
I wish.. :thefinger::laughing:

No.. Seriously.. It sounds like it has a cold.. Ever since I dunked the font end at a mud hole in RC.. It hasn't worked right since.. :grinpimp:
 

·
Registered
Joined
·
1,708 Posts
Discussion Starter #11
I wish.. :thefinger::laughing:

No.. Seriously.. It sounds like it has a cold.. Ever since I dunked the font end at a mud hole in RC.. It hasn't worked right since.. :grinpimp:
yeah i had that problem too... didnt work "right" but it still gave an effort to bellow out like a dying seal...

but i know it worked before i took it in so it has to be a wire or fuse somewhere...
 

·
Registered
Joined
·
2,073 Posts
yeah i had that problem too... didnt work "right" but it still gave an effort to bellow out like a dying seal...

but i know it worked before i took it in so it has to be a wire or fuse somewhere...
Check the connector also.. Mud or water could have gotten into it.. Make sure it isn't grounding out or something..
 

·
Registered
Joined
·
2,832 Posts
i poked around under the hood the other day, but didnt really see where the horn is at... any help there?
Behind the drivers side headlight. I took mine out a year ago or so, I don't really remeber what it took, but I can check for you today after work.
 

·
Registered
Joined
·
1,121 Posts
best way to check would be to take a meter and check to see if the circuit is passing voltage while someone hits the horn button. If the circuit is good then the horn is bad, If circuit is bad then its likely a fuse or relay somewhere. I had to switch mine out after I had the dying seal sound for about 2 months then it finally quite and I got no sound at all from it.
 

·
Registered
Joined
·
447 Posts
Might sound stupid but check the connector, I did have the problem on mine and it was just one of the connector on the horn, it was not clamp properly. But the stock horn…just plain suck decided to put this one couple week ago , I love it most annoying sound ever.



YouTube - oogaa wrangler jk
 

·
Registered
Joined
·
1,708 Posts
Discussion Starter #16
thanks guys... took the horn out today... boy talk about dirty connections... cleaned it up and will put it back in after work... hopefully she works...


reason i dont just take it to the dealership and as for a spot check is because the dealer close to me is crap, and i really like the dealer i bought it from... only problem with that is it is an hour away...
 
1 - 16 of 16 Posts
Top