JKOwners Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Okay so I have a 2016 JKU Willy's edition. I have a pair of Rigid industries D series midnight edition lights that I ran through my fire wall into my rugged ridge switch. First time I powered them on they looked great, however the led stayed on all the time on my rocker switch so I switched up the wiring and nothing worked so I went back to the original wiring that worked but left the LED on. Then this wouldn't even work so I connected new disconnects and checked the wiring and everything looked good. Will someone please help me with what I'm doing wrong this is my first big mod.
Thank you,
Parker
 

·
Super Moderator
Joined
·
6,179 Posts
Okay so I have a 2016 JKU Willy's edition. I have a pair of Rigid industries D series midnight edition lights that I ran through my fire wall into my rugged ridge switch. First time I powered them on they looked great, however the led stayed on all the time on my rocker switch so I switched up the wiring and nothing worked so I went back to the original wiring that worked but left the LED on. Then this wouldn't even work so I connected new disconnects and checked the wiring and everything looked good. Will someone please help me with what I'm doing wrong this is my first big mod.
Thank you,
Parker
well, without a picture or two & maybe some crude drawing of the schematic as-to how you have made connections on everything, there is no tmuch we can tell you, dude.
Are you running to a relay as you should be ( even for LEDs it's good practice) ? If you have run your hot directly to the battery terminal POS+ is it fused? that rocker switch is getting constant power , obviously. Have you used a fused circuit into an appropriate fusebox fuse for powering it only when keys turned ON instead?
I would like you to get started on JKOwners in good order, bud.
Later, hit the welcome room and intro yourself but re: this HELP! request, an image host like Photobucket, google photos, imgur, etc....will be a big benefit for you to show folks on here what you're referencing on sh*t like this.
There are crazy amounts of reliable "how to wire _____ through the Rugged Ridge Rocker Panel on a Jeep JK" search results via Google until you get us someinfo to help better with, cool?

welcome to jkowners, btw. :bounce:
 

·
Registered
Joined
·
88 Posts
I'm going to make assumptions without any better information.
You are using the standard rocker switch (Single Pole, Single Throw). Most likely part number 17235.01.

Without much information my guess would be miswired switch. Can you use a multimeter to check voltage? Check voltage at the back of the switch. Pin 3 to ground (any shiny metal part of the body or engine) should read 12v either constant or when you have the ignition on depending on how you wired. If not check the fuse or method of wiring the power wire.

With the switch off pin 2 to ground reads close to 0V.

Turn the switch on, Pin 2 to ground should now read 12v.

The switch is wired correctly. Now recheck voltage where you connected the wire to the light. Lastly make sure you have a good ground connection. Check battery terminal to ground point.

Look here for switch wiring diagram. Ignore the bottom.
http://www.omix-ada.com/instructions/17235.01.pdf
 
1 - 3 of 3 Posts
Top