JKOwners Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hey guys,

I am a new JK owner, and I have to say that I couldn't be more excited. I used to own an '04 Liberty, but finally was able to get my dream vehicle and upgraded to a wrangler ('08 JK Sahara).

Experiencing the notorious throttle lag with the '08 3.8L V6 made me look for something to improve this. I am a beginner in the JK community, and after doing quite a bit of thread reading, I decided to try the Sprint Booster.

After installing per various thread instruction and Sprint Booster instructions, I experienced a couple of problems.
1. The ETC light flashes on the dash
2. Engine revs to 2500 rpm immediately upon starting

Returned to stock throttle control and all is well, but I would really like to get this thing working correctly.

Any direction/tips would be great with this.

Thank you,

DJB
 

·
Premium Member
Joined
·
5,705 Posts
Maybe the unit is defective ?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
I sure hope that is not the case. I was so excited when it first came today. Plan to re-install it tomorrow to try and get it to work. Any common problems come to mind when installing these badboys?

DJB
 

·
Registered
Joined
·
1,612 Posts
hi.. you have the plug the wrong way... switch it around and you will be fine.. ive seen that happen a couple times... its hard to see down there and sometimes people plug it in backwards :beer: it does help the jk "feel" faster.. takes away the annoying lag. good luck ! oh also congrats on the jeep .. you will love it
 
1 - 5 of 5 Posts
Top