JKOwners Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello All

I need some help, I bought a 2008 jk rubicon 4 door, I put a 4" teraflex short arm on it, I now have a vibration that i can't find. i have took it to the installer and to the front end shop so many times that i can't count, i ordered and put on new teraflex drivelines and took off the short arm and installed the long arm, not fixed . I called teraflex and took the jeep to them, they have been great but
can't find the problem, the jeep was stock with no vibration before the lift.
CAN ANYONE HELP:
CHUCK IN ARIZONA
 

·
Registered
Joined
·
2,864 Posts
When does it vibrate? At what speeds and/or RPM? And did you change tires...if so, to what kind?
 

·
Registered
Joined
·
2,518 Posts
Sound to me like you need to get your drive shaft angles dialed. Pull the front shaft and see if it disappears. You will need to determine what shaft its coming from. Ideally, your pinion needs to be parallel with your drive shaft to eliminate vibes with a double cardan joint.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
it starts at 55 and gets realy bad at 65, changed the tires to 35 bfg, it had vibration trouble before the tires, I changed them hoping that would fix the vibration, it did not, the jk has 50,000 , I called teraflex and they have been very good to me, they have had the jeep for about 3 weeks and r still trying to find the reason for the vibration, I was hoping that someone else had this trouble and knows how to
fix it.
 

·
Registered
Joined
·
1,776 Posts
It has been my experience that the factory specs for toe in can cause vibration at those speeds. I set my toe at 0 or 1/16" toe out. This seems to take care of most of the vibration but with mine I am also sure that my tires have a lot to do with the small amount of vibration I still have. Give it a shot. You can always set it back to factory specs if needed.
 

·
Registered
Joined
·
189 Posts
First you should go back and double/triple check all the bolts that you touched to see if it is ALL tight. If it is still present Definitely pull off the front driveline and see if it helps.
Did you tighten the Track bar back up, like really f-n tight?
Your Toe in and out shouldn't have changed that much.
Um, Make sure the top of your front shock nuts are tight also, I remember I found mine loose after I had help installing my TeraFlex lift, and it caused me a vibration at speeds.
Good luck and hope you find the issue.:beer:
 

·
Registered
Joined
·
10,290 Posts
mine gets a high frequency vibe above 75. i think it's castor playing hell on the front ujoint in the driveshaft though...
 
1 - 9 of 9 Posts
Top