JKOwners Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
So all of a sudden while driving, my dash is going crazy. Traction control light, ESP light, sway bar light, oil pressure light, airbag light flash non stop and my tach needle bounces all over.

The jeep wouldn't start yesterday and my battery was reading very low so I swapped for a new one thinking that was the problem.

Its still doing the same thing. I pulled codes with my bullydog.

U0001 high speed can communication bus

U0141 lost communication with body control module

U1113
U110e
U110a
U1403
U110c

A week ago I attached a quick connect cable to the battery for my winch but havent gotten around to attaching the cables to the winch end so maybe moisture got into the quick connect end? That is not attached to the new battery at the moment.

Is my computer toast??

Any help would be appreciated...
I hope I don't get stranded on my way home from work lol.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #2
After found some research online, I've seen a few people say that if there are any gaps in the battery terminals or if they aren't seated properly, this can be the problem and tightening can fix it.

It did start happening after I was messing with the terminals to add those quick connect wires for the winch. I'll go double check and see if thst makes a difference.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #3
So after tightening everything connected to the battery.... My jeep won't start.

The dash has the sway bar light flashing. I go under to look at it and the electrical connector is loose.

I tighten it and magically the jeep starts and runs fine.

I can't believe that stupid connector can mess up the entire computer. Man i hate when things are overly computerized. Like my dishwasher which never works.

Anyways... im both happy but astounded. I hope that was the end of it.
 

·
Gunnery Sergeant USMC (ret)
Joined
·
22,098 Posts
That doesn't make sense. I know lots of people that don't even have the smart bar connection hooked up and their jeeps run fine.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #5
Driving home from work this morning, got a U0001 code - high speed CAN communication BUS. The Jeep is driving perfectly fine though. Oh the suspense of what will happen next...
 

·
Registered
Joined
·
22 Posts
Discussion Starter #7
So I filled the e disco with dielectric grease and zip tied the electrical connector shut. Now my sway bar light won't stop flashing. The fun continues..
 

·
Registered
Joined
·
85 Posts
So I filled the e disco with dielectric grease and zip tied the electrical connector shut. Now my sway bar light won't stop flashing. The fun continues..
In my experience working on several electrically controlled machines too much dielectric grease can cause more issues. Even in JLG and Genie trouble shooting it's the first step to clean out dielectric grease.
 

·
Registered
Joined
·
50 Posts
Sorry I'm late to the party, but if this is a still an issue...

This was a recurring issue with me. Heres my thread on JKF. --->

https://www.jk-forum.com/forums/stock-jk-tech-12/stock-rubicon-sway-bar-actuator-no-start-condition-general-chaos-331865/#post4198832

I ended up disconnecting and disabling the bar entirely. JKS Quicker discos FTW!!!

Side note, just disabling the bar will not stop the problem, as it drags the whole CAN down to ground.

EDIT:

You can use a procal to remove the Smart Bar function completely. Its ~1300 to buy a new smart bar. Buy discos.
 

·
Registered
Joined
·
50 Posts
The indicator will flash indicating there is a problem with the smart bar (the module may be damaged/full of water).

Leave the bar disconnected and see if the problem continues. That light will always flash as long as it doesn't detect the bar, or believes there is a problem with it.

If you have a superchips or procal, disable the bar, disconnect it, and drive around. See if your dash does the funky chicken anymore.
 
1 - 12 of 12 Posts
Top