JKOwners Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I've seen a few threads tangentially related to this, but cannot figure out the fix...
I have a 2013 JKU and I had an incident where the steering wheel controls stopped working (dry pavement, no rain), then the next time I unlocked it, with key or remote, the horn would sound for 30 seconds straight, no matter what I did, then quit, but not work an ANY OTHER TIME. Unhook the battery, discharge the residual charge (Pos to Neg >5min). hook battery back up, horn sound >30 secs. unlock or open the hood, horn sounds, etc.
Figured it was clockspring, have a recall notice, took to stealership. They said it was a "stuck horn switch". I replaced the switch-no diff myself, (Yes I know how to do it correctly). Took it back to the stealership who said they "replaced the clockspring", but I have the same result. 'Hooooooooooooooooooooooooonk" 30 secs. no workee otherwise...
QUESTION: Is there a relay somewhere that controls the horn? HELP (please). I NEED MY HORN!!!! (i'm a transplant in Alabama...)
I've seen a couple of pics online that seem to indicate there may be a relay in the TPMS that "may" be accessible?) ????

NEXT

The second issue (maybe related-maybe not)
Right fog quit working, figured it was a perfect opportunity to change heads and fogs to LED. Changed-got a cheap version of heads/fogs. right fog still doesn't work. swapped left/tight. right still doesn't work. Plus, the cheap LED Heads sucked. So bought better heads. they work great -WAY better than the cheapos, but now, my right DRL doesn't work- it worked, then quit working after a few cycles.
Question- can this be related to a CANBUS harness? Do I need to buy one of them? I've seen that maybe they increase the lower LED Bulbs resistance and that the LED's lower resistance can cause issues with the TPMS?

ANY advice would be appreciated. For the fogs, I have 12.4v at both OEM and pigtail harness, but RH fog doesn't work when I connect it....haven't checked the RH DRL for voltage.

Please help, and I apologize if this has been answered elsewhere-I just couldn't find it.
 
1 - 1 of 1 Posts
Top