JKOwners Forum banner
41 - 45 of 45 Posts

·
Registered
Joined
·
64 Posts
I got the radiator in the Motech kit. Not sure what it is.

I had to move the ecm forward because I have the J8 master cylinder which pushed it all up.

Never thought about putting the bottle at an angle, I’ll take another look. So far I’m just letting it puke out it only runs about an inch low.
 

·
Registered
Joined
·
64 Posts
I replied to your PM, but I can't tell if it sent or not. Let me know if you didn't get it.



I thought I had it bad, you had to do some major routing. I'm curious, what radiator is that? Mine is the CFS 3466 which is for my 09' with 3.8 engine. I think there is a better solution with radiator outlet placement than what we both have. I went with the silicone hoses which took a lot more splicing. Again, I would like to run the outlet hose from the pump under the fan rather than above to open up space. BTW, you might free up space for that overflow tank by moving your E-92 and TCM. I just made a bracket to secure the tank.
 

·
Registered
Joined
·
64 Posts
So I have more seat time on my swap and I think I made a mistake with my gear selection. I'm running 40" tires with 5.38 gears. It's hard for me to make the engine work and it seems that it revs up too quickly. Anyone running a 8l90 want to let me know what gears you went with, tire size and your impressions?
 
Joined
·
786 Posts
If you do a radiator with the inlet on the upper left it will lay our much easier than trying to run the upper hose across the radiator to the right.

I saw in one of the pictures that it looked like the lower hose was brought up and ran on top of the fan and then down to the bottom of the radiator. I would not do that as it could trap air. You want the lower hose to go down and stay low.
 

·
Registered
Joined
·
206 Posts
If I remember correctly, Robbie mentioned in one of his videos that they solved the traction control and battery light issue. I'll have to go back through them and confirm.

Sent from my SM-G950U using Tapatalk
Does anyone have an answer to this? My builder has gotten the battery light to extinguish when the Jeep side was flashed, but there is still a solid ESP (traction control) light illuminated. FYI I have a 2012 JKU Rubicon that now has an L86 and 10L80 transmission.
 
41 - 45 of 45 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top