JKOwners Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
97 Posts
Discussion Starter #1
Stupid question but is anyone having issues with their stereo radomly shutting off while driving? I have a 2012 with the upgraded stereo (GPS) and about a half dozen times no since I bought the jeep the stereo just randomly shuts off, after a couple seconds the stereo turns back on but has to "re-boot". Any known issues on this?
 

·
Registered
Joined
·
256 Posts
mine did that as well, i have an aftermarket Pioneer with GPS and it did that once or twice a week then stopped doing it a couple weeks ago and hasn't happened since.

no clue what causes it, but if it happens again, i am going into the shop with it
 

·
Registered
Joined
·
12 Posts
Open up your fuse box and make sure everything is pushed down, your dealer was to lazy to do this it ships from the factory this way.

If you look at your speedo you should see a message saying no fuse when it happens
 

·
Registered
Joined
·
3,887 Posts
Funny- I have an '07 with the standard radio/cd player. A few months ago it started doing the same thing. There was no rhyme or reason for when it would turn off, just total random. A couple weeks ago I got sick of it happening, and just replaced it with an aftermarket stereo. All is good now, and I'm much happier since I can control my ipod from this new stereo.
 

·
Registered
Joined
·
687 Posts
My 07 with aftermarket stereo does it too. No rhyme or reason. Sometimes it goes off when I hit a bump, other times I am just sitting parked with the key in ACC...

I have yet to figure it out.
 

·
Registered
Joined
·
285 Posts
My 07 does it as well but seems tied to the clutch...kinda like if you kill it by letting off the clutch with no gas. Every once in awhile it'll go through a phase where everytime I let off the clutch the radio dies and comes back on. :cwm13:
 

·
Registered
Joined
·
430 Posts
I find mine will cut out the odd time when using the power window buttons to close the windows, the radio shuts off completely for about 2 secs, then comes back on
 

·
Registered
Joined
·
68 Posts
Open up your fuse box and make sure everything is pushed down, your dealer was to lazy to do this it ships from the factory this way.

If you look at your speedo you should see a message saying no fuse when it happens

X2 - Radio worked, but the sound was ZERO, popped the hood and the fuse to the amp was not inserted completely. I simple goof by someone.

Paul
 

·
Registered
Joined
·
12 Posts
JK OEM Radio cuts out, but everything else works

I haven't yet delved into this (a little reluctant with the anti-theft feature) but my radio will usually cut out after a few seconds of being on. It has gotten worse. But the cd player, USB, etc all still work.

Once in a great while the radio portion will turn back on for a few minutes. No correlation to bumps or anything else I've been able to observe. Completely random.

Could the antenna cable be loose into the radio? But it doesn't just go to static, it actually becomes silent.

Any ideas anyone out there?
 

·
Registered
Joined
·
97 Posts
Discussion Starter #11
I had completely forgotten I started this thread 3 years ago.

I am still having the issue even after having the radio replaced by the dealer, I have just given it up and chalking it to being "a jeep thing". For me every once in a while I start the jeep and the radio has to "re-boot", like it lost power. Presets are still saved but equalizer settings are back to neutral, volume for all three options (phone, radio, nav) are all at zero with no sound, radio is set to AM and when go to satellite it goes to the preview station. No idea what is causing it but like I said I just kind of gave up and am chalking it up to something I have to do every once in a while
 

·
Registered
Joined
·
291 Posts
I've seen a lot of different gremlins resolved by replacing the TIPM. Weird radio issues, intermittent cruise control issues, random turn signal and horn issues, etc.
 

·
Registered
Joined
·
1 Posts
Same thing keeps happening to me, exactly!!! did you ever find out the cause? My dealership is replacing my radio to see if it fixes it.
 

·
Registered
Joined
·
1 Posts
I have had the same issue with 2 aftermarket stereos and have been finally told bi Pioneer that the issue is the lack of air circulation around the stereo causing it to overheat. I am trying to figure out something I can do to fix this issue (fan, air, etc.)
 

·
Registered
Joined
·
1 Posts
Stupid question but is anyone having issues with their stereo radomly shutting off while driving? I have a 2012 with the upgraded stereo (GPS) and about a half dozen times no since I bought the jeep the stereo just randomly shuts off, after a couple seconds the stereo turns back on but has to "re-boot". Any known issues on this?
This happened to me two years ago except i also had smoke pouring out of the dash and one of my speakers blew just before. I brought it to the dealer and they disconnected it but wouldn't fix it for free because i was 500 mile out of warranty. i complained about it and the head of service went in and grabbed me a stereo from the shelf and said if i new someone that could install it i could have it. well i installed it and that one didn't work either. I called and called and never got a call back. I will never buy from Herb Chambers again because their service department sucks. oh and i still don't have a stereo. I do still love my jeep ♥
 

·
Registered
Joined
·
1 Posts
I have an 07 with a stock radio. I bought the Jeep used, a few months ago. Some times when I turn the key the radio comes on and works perfectly normal. And sometimes the screen comes on, but it is basically blank. The template shows up but there seems to be no data coming in (station list is blank, etc.) and the radio does not play. I can plug in my iPhone and play music from it. But the radio just doesn't play. And then the next time I turn on the ignition the radio plays as normal. I have no idea why it does that. I haven't checked the fuses or connections, but I'm about to try that.
 
1 - 16 of 16 Posts
Top