JKOwners Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
2,910 Posts
Discussion Starter #1
Jeep is a 2008 automatic trans that had the engine and tranny replaced this past summer due to hydrolock. the new (to me) engine already had the Ripp stage 2 supercharger on it. This past weekend there were a lot of steep muddy hill climbs that involved some full throttle assaults. Several times as soon as I let off the throttle the jeep stalled and died. While sliding backwards I was always able to slap it into neutral and get it started again. Any ideas on what could be causing this?

I have also been having some issues with the blow off valve releasing pressure before shifting while accelerating. Not sure if these issues are related?
 

·
Registered
Joined
·
896 Posts
Jeep is a 2008 automatic trans that had the engine and tranny replaced this past summer due to hydrolock. the new (to me) engine already had the Ripp stage 2 supercharger on it. This past weekend there were a lot of steep muddy hill climbs that involved some full throttle assaults. Several times as soon as I let off the throttle the jeep stalled and died. While sliding backwards I was always able to slap it into neutral and get it started again. Any ideas on what could be causing this?

I have also been having some issues with the blow off valve releasing pressure before shifting while accelerating. Not sure if these issues are related?
A couple of things that we would like you to do:

If your kit came with a Diablosport I1000 intune (looks like a little Iphone) please plug it into any internet enabled WINDOWS computer and see if there are any tune updates.

If it is not an I1000, please check to see what Version of tune you are running. (Version 3.3 is the final 3.8 tune)

Are there any check engine lights?

Please take a datalog with the included diablosport tuner while replicating the issue if possible, please email the datalog file along with the files that say "last tune written" and "original Backup file" to [email protected]. Please also include a brief description of your problem in the email. If you have any other questions please call us M-F 9a-5p EST at 718-815-1313 ext.11 or email [email protected] for general tech info.

RIPP
 

·
Registered
Joined
·
2,910 Posts
Discussion Starter #3
A couple of things that we would like you to do:

If your kit came with a Diablosport I1000 intune (looks like a little Iphone) please plug it into any internet enabled WINDOWS computer and see if there are any tune updates.

If it is not an I1000, please check to see what Version of tune you are running. (Version 3.3 is the final 3.8 tune)

Are there any check engine lights?

Please take a datalog with the included diablosport tuner while replicating the issue if possible, please email the datalog file along with the files that say "last tune written" and "original Backup file" to [email protected]. Please also include a brief description of your problem in the email. If you have any other questions please call us M-F 9a-5p EST at 718-815-1313 ext.11 or email [email protected] for general tech info.

RIPP
Might take a while to get the info on a computer. All the computers in the house are Macs as well as all our work computers.
 

·
R.I.P. Mr. Nibbles!
Joined
·
8,956 Posts
Bootcamp or Parallels. Chop chop! :D
 

·
Registered
Joined
·
8,296 Posts
How steep? The JK doesn't like being at extreme angles. I got stuck on Rock Pile and engine started to cut out and die probably either because of fueling difficulties at that angle or because the computer decided it was time to shut down because of oil starving issues in the trans. Same happened on the exit of Upper Helldorado for the same reason.
 

·
Registered
Joined
·
2,910 Posts
Discussion Starter #7
How steep? The JK doesn't like being at extreme angles. I got stuck on Rock Pile and engine started to cut out and die probably either because of fueling difficulties at that angle or because the computer decided it was time to shut down because of oil starving issues in the trans. Same happened on the exit of Upper Helldorado for the same reason.
not VERY steep. I had been up it several times before when it was dry no problem.
 

·
Registered
Joined
·
689 Posts
Not on a JK, but I know first hand that a bad O2 sensor can cause the engine to die after a WOT run. No SES/Engine light either. Talk about a real pain to figure out.

Let us know what you find out.
 

·
Super Moderator
Joined
·
6,179 Posts
Not on a JK, but I know first hand that a bad O2 sensor can cause the engine to die after a WOT run. No SES/Engine light either. Talk about a real pain to figure out.

Let us know what you find out
.
do you mean that you havent confirmed that this issue exists on a JK or that it isnt possible on a JK? it seems like useful knowledge to tuck away but i cant tell what your statement has to do w/ the OPs issue unless it might pertain [ not being a jerk; just always trying to learn useful JK data!]...
 
1 - 9 of 9 Posts
Top