JKOwners Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
99 Posts
Discussion Starter #1
The front turn signal connector on my '09 Rubicon has corroded and failed. Not the bulb, but the connector on the wiring harness itself. To be more specific, the middle wire corroded and came off, so now I have no parking lamp feature. Does anyone know a part number for this? I am still under warranty, but to waste a day at the dealer for this is not something I want to do.

 

·
Registered
Joined
·
345 Posts
The front turn signal connector on my '09 Rubicon has corroded and failed. Not the bulb, but the connector on the wiring harness itself. To be more specific, the middle wire corroded and came off, so now I have no parking lamp feature. Does anyone know a part number for this? I am still under warranty, but to waste a day at the dealer for this is not something I want to do.

From what I could see in the parts manual, this is not available as an individual part, only as the whole wiring harness.

Easiest/cheapest would be to go to Auto Zone or similar and get the appropriate connector for the type of bulb (with pigtail), and splice that onto your harness.
 

·
Registered
Joined
·
99 Posts
Discussion Starter #3
From what I could see in the parts manual, this is not available as an individual part, only as the whole wiring harness.

Easiest/cheapest would be to go to Auto Zone or similar and get the appropriate connector for the type of bulb (with pigtail), and splice that onto your harness.
Maybe I'll have to let the dealer fix it then. I like your idea of finding the appropriate connector, but the issue I see is that this is a three piece system. The bulb, the socket adapter deal the bulb plugs into, and then the wiring harness piece that is screwed up that plugs into the socket adapter. I can't just wire in a universal socket that fits the 3157 bulb because it has to twist lock back into the turn signal housing somehow....
 

·
Premium Member
Joined
·
4,945 Posts
I am on my phone but I have the Chrysler website for wire/connector repairs on my computer-broke my tb connector and ordered just that kit for$25 instead of the whole harness. Will try and find it and post up.

Found it-

http://dto.vftis.com/mopar/main.asp

Didn't check for this specific "part" but they have a ton of shit listed-
 

·
Registered
Joined
·
99 Posts
Discussion Starter #5
I am on my phone but I have the Chrysler website for wire/connector repairs on my computer-broke my tb connector and ordered just that kit for$25 instead of the whole harness. Will try and find it and post up.

Found it-

http://dto.vftis.com/mopar/main.asp

Didn't check for this specific "part" but they have a ton of shit listed-
Thanks for the link. This is the kit I came up with, think it's the correct one?

Mopar Package #
68065016AA

LAMP-PARK/TURN-RIGHT FRONT (EXCEPT EXPORT) - BLACK (HEADLAMP) 3 WAY

CAV CIRCUIT FUNCTION

1 L160 20WT/TN RIGHT FRONT TURN SIGNAL CONTROL

2 - -

3 Z904 20BK GROUND
 

·
Registered
Joined
·
3,691 Posts
Sorry man... I can't find them. I did completely remove them though. I'll let you know if I can find them when I put on my wheels.
 

·
Registered
Joined
·
99 Posts
Discussion Starter #7
Sorry man... I can't find them. I did completely remove them though. I'll let you know if I can find them when I put on my wheels.
No problem. I might go check out the delco part number you gave me, as it looks like they sealed the wires on that one. The Jeep connector really is a poor design, and I'm sure submerging my connections in water crossings hasn't helped :laughing:
 

·
Registered
Joined
·
268 Posts
I know this is a old thread but can anyone verify that the part number listed above works for a 2013 JKU?
Thanks.
 

·
Registered
Joined
·
1 Posts
The front turn signal connector on my '09 Rubicon has corroded and failed. Not the bulb, but the connector on the wiring harness itself. To be more specific, the middle wire corroded and came off, so now I have no parking lamp feature. Does anyone know a part number for this? I am still under warranty, but to waste a day at the dealer for this is not something I want to do.



There is a pigtail connector u can get at the dealer that replaces this. The mopar part number is “6808 5016 AB”
 
1 - 9 of 9 Posts
Top