JKOwners Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
please read and let me know if you have any idea what it could be...

i started my jeep up the other and every dash light came on and made a slight buzzing noise at the same time. when i turned the jeep off and took the keys out, a round red light in the upper right corner of the jeep stayed on solid. While the jeep was off, the speedometer lights would flicker on and slowly dim out. I could still put the jeep in drive at this point. i tried starting it about 3 different times and it kept doing the same thing. I then unhooked the battery hoping it would reset everything. After unhooking the battery and then hooking it back up, i tried to start the jeep and no lights on the dashboard came on, the windshield wipers would not go off, not would the headlights go off. Anything controlled by the steering column and dashboard will not work and will not light up. Also after unhooking the battery, the car won't go in drive. The A/C will work, but not blow cold air. My first theory was it had something to do with the Alarm system considering the red light, but the alarm was never triggered. The jeep starts fine and drives fine, but has no working dash lights. I have not had any electrical problems prior to this. i had all doors off for 7 days prior to the problem, but no rain at all touched the car the entire time. this may have nothing to do with the problem but any info may help at this point. its a 2009 JK with 65k miles on it. thanks guys
 

·
Registered
Joined
·
148 Posts
please read and let me know if you have any idea what it could be...
Bad news is, everytime i have seen this issue, it has been a TIPM ... its not cheap, but have it replaced at the dealership...

BTW, dont hesitate to call Chrysler and ask for assistance... i have seen them tell people to "pound sand" and i have seen them replace them for people... its worth a shot
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
well, after 2 weeks of sitting in the driveway. i started the jeep up and everything was normal. the Malfunction indicator light came on for a little while, but it is clear as well. crazy stuff
 
1 - 3 of 3 Posts
Top