JKOwners Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
90 Posts
Discussion Starter #1
Does anyone else experience cold start knock?
Yesterday it was about 26*F on the dash thermometer and I had cold start knock for about 5 seconds.

I am not looking for a lesson on what causes this so much as if anyone else experiences it.
 

·
Registered
Joined
·
90 Posts
Discussion Starter #3
Thanks, very likely that's what it is. It's only happened once since my oil change (last weekend with a wix filter). If it happens again I'll get a filter from the dealer.
 

·
Registered
Joined
·
285 Posts
I've had good luck with Carquest filters. Also I'm running 5w30 synthetic. I had start up knock using K&N oil filterand Fram regular orange but the Fram tough guard was OK. Ive been running the carquest filters for the last 3 oil changes and nothing.
 

·
Registered
Joined
·
157 Posts
Had it and switched to Fram Tough Gard and its all better now and we have had some cold mornings here lately and she doesn't knock no more :)
 

·
Registered
Joined
·
38 Posts
Napa has a filter that i have had good luck with its the napa platinum filter from wix. i belive its a synthetic fiber for use with synthetic oils i also use penzoil ultra 5/20 with 8k intervals

seems to work for me i dont have a know neither does my wifes 2009
 

·
Registered
Joined
·
1 Posts
I had a bit of knocking as well, but just recently switched from a fram tough gaurd to a Bosch filter and don't think I will run anything else. No More knocking:beer:
 
1 - 7 of 7 Posts
Top