JKOwners Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
For a couple weeks, my clock (in radio) resets itself to 12:00 every time the ignition is turned off. This is annoying.

Also, perhaps related, when the ignition is turned off, the engine continues to run for a second before it dies. It doesn't shut down immediately when power is off.

No codes are shown on the instrument panel and my plug in OBDII reader doesn't show anything. What's up?
 

·
Registered
Joined
·
46 Posts
I have the same thing right now, runs for an extra second after turning it off and clock keeps resetting except mine doesn't always go to 12:00. Haven't looked into it yet but it is definitely annoying.


Sent from AutoGuide.com App
 

·
Registered
Joined
·
340 Posts
Mine did the same thing. There was a glitch in the head unit and chrysler was aware of the issue. It was fixed under warranty.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #7
It fixed itself today. Through about 4 ignition on/off cycles, the clock has returned to the correct time. I didn't do anything to make this happen; no battery disconnect or anything else that might be related.
 

·
Registered
Joined
·
148 Posts
This may seem weird, but, the clock is told the time from the WCM (the module that handles the anti theft key ).Chrysler doesn't tell me which model this stands true for.
It is common for us to see clock issues, and I am told there is no rhyme or reason for it, at one time, mine would drop 4 hours while driving down the road.
First thing I would check is power to the radio though and be sure your not losing the keep alive memory power as this affects it too
 
1 - 8 of 8 Posts
Top