JKOwners Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
900 Posts
Discussion Starter #1
does anyone one have any issues with the check engine light coming on for a day or two then go off?

the first time this happened i took it to the dealer and said there is nothing wrong with it. I also checked my turning the keys three time and no error codes came up. this has happened to be three time now and not sure why.
 

·
Super Moderator
Joined
·
15,337 Posts
I am having the same identical issues. Mine came on for seemingly no reason- went off a few days later....did this 3 times. In the course of that time, I took it to the dealership and they said there was 3 stored codes....not active (idle/ air sensor- and 2 others- can't remember)....scheduled it to be looked at....and the next day- it was back off again...so they decided that they didn't want to look at it unless it came back on.

Dealership said that it was common to cycle like it had 3 times- before the code would clear. :shaking:.

Last week it came back on a few hours after I had them change the oil. Today I went ahead and put about 40 continuous miles on the Jeep- and when I stopped for gas and turned it off and back on- the MIL was gone again.

Have absolutely no idea what is causing this- but Jeep is running fine. I have not had any "actual" issues. I will let you know if I find out anything at all.
 

·
Registered
Joined
·
1,186 Posts
1) I bought a nice code reader from an ebay seller for 50.00, which also allows me to view freeze data, as well as the code.

2) Just curious, did you fill up with the engine running?

But having the actual codes is probably the real key to solving the problems.
 

·
Registered
Joined
·
37 Posts
I had the same exact issue with less than 1200 miles on my Jeep. We had gone down to the beach and were wheeling through some seriously deep sand. I had pulled a Chevy 2500HD out and was on my way back to our camp site when the dreaded light came on. It was running just fine, but the light stayed on for two days. On our way home I had stopped to top off the tank, it stayed on... made another stop 45 minutes later and after starting up the Jeep it went away finally. Took it to the stealership and there were no stored codes. No problems since.
 

·
Super Moderator
Joined
·
15,337 Posts
2) Just curious, did you fill up with the engine running?

But having the actual codes is probably the real key to solving the problems.
I've never filled up with the engine running.

Tried turning the key on/ off 3 times but nothing came up- I guess b/c there was nothing "active"...not sure. I have no doubt that the MIL will come back on.
 

·
Registered
Joined
·
1,186 Posts
You knew where my thinking was.

The nice thing about those code readers is the code doesn't have to be active.
 
1 - 6 of 6 Posts
Top