JKOwners Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi guys,

Have a 2011 Unlimited. About 5 months ago, had to have the throttle body adjusted due to some rough idling. Got a check engine light at the time. Since then, no issues. However, whenever I turn the key to the "ON" position (before turning to "Start", where all the electronics turn on), the check engine light keeps coming on. Then, when I start the engine, it goes away. Not sure WTF is going on - maybe it's not a big deal, but I hate seeing it come on every time I go to start the car and the last time I took to the dealership, nothing changed. For just under a year since I purchased, I don't expect ANY lights to remain on that shouldn't.

Thoughts?

Thanks!!!
 

·
Registered
Joined
·
277 Posts
i am pretty sure that when you turn the key from off to power( not start) all the system lights run checks. the engine light stays on. once you turn the key again and start the jeep if there is no codes/engine problems the light goes out almost right away.
 

·
Registered
Joined
·
990 Posts
The Check Engine (Along with nearly every light on the dash) comes on when turning the key from off-to-on. The Check Engine light should go out with in a few seconds of the engine starting. Every Vehicle works this way.
 

·
Registered
Joined
·
4 Posts
Dash lights

ESP/BAS,Anti-Skid and ABS lights come on at start and don't go out. And the brakes drag fo a bit when I star to roll. Auto zone founnd no codes and thoughts
 

·
Registered
Joined
·
335 Posts
ESP/BAS,Anti-Skid and ABS lights come on at start and don't go out. And the brakes drag fo a bit when I star to roll. Auto zone founnd no codes and thoughts
The most common reason for this is an alignment issue or something bent in the front end. The brakes are reacting to a misalignment in the front end geometry and the system is trying to keep you safe. Check the tie-rod (most common bent part of the system) and then look at everything sale. Check for loose bolts or even broken welds. If nothing is visually wrong, go somewhere that has s trusted alignment rack and get it aligned.

Hope this helps?
 

·
Banned
Joined
·
16,618 Posts
ESP/BAS,Anti-Skid and ABS lights come on at start and don't go out. And the brakes drag fo a bit when I star to roll. Auto zone founnd no codes and thoughts
Lights could be due to a trashed wheel sensor. The dragging could be the uphill assist just doing its thing. See if it does the same thing on a downward incline when you're getting going. If it does not drag the brakes a little on the downward incline, your Jeep is functioning normally.

Have you tried to disable ESP/ABS by pressing the button on the dash that looks just like the light? Maybe you disabled it at one point and forgot to swap it back?
 

·
Registered
Joined
·
335 Posts
Lights could be due to a trashed wheel sensor. The dragging could be the uphill assist just doing its thing. See if it does the same thing on a downward incline when you're getting going. If it does not drag the brakes a little on the downward incline, your Jeep is functioning normally.

Have you tried to disable ESP/ABS by pressing the button on the dash that looks just like the light? Maybe you disabled it at one point and forgot to swap it back?
Good call Dan! I always overlook the sensor. Hopefully its something simple!
 

·
Registered
Joined
·
398 Posts
ESP/BAS,Anti-Skid and ABS lights come on at start and don't go out. And the brakes drag fo a bit when I star to roll. Auto zone founnd no codes and thoughts
Check the ground wire on the driver's side fender by the brake master cylinder. I did some electrical work and forgot to put the ground back on and had the same symptoms.
 
1 - 9 of 9 Posts
Top