JKOwners Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I just put on my lift on my JK in the beginning of the summer (3" tereflex, 35's, shocks, track brackets) and I unplugged the ABS to stop the car from freaking out cause of the lift between traction control and ESP. So now my ABS, ESP, and traction control lights are on, but my car runs great for the most part. But half the time when I turn my car on whether i warm it up or not and take off, right away it will start to loose engine power, even the RPM's wont go up. I will press the gas it will go then just stop speeding up and even slow down as hard as i press the peddle. and this is in 1st gear... It is almost like it is going into some default mode maybe thinking the ESP is still there, then I let go of the gas and hit it again once or twice and it will drive normally until i turn the car off and it begins again.

In addition I took it of road today for the 1st time and it did very well rock climbing and what not, until I went back down and out the trail the problem began again and continued as many times as I pumped the gas, it just didn't correct itself. (drove it on trail in 4 low mostly)

If anyone knows what the problem is or is facing the same problem please let me know... It is so frustrating!!!
 

·
Registered
Joined
·
1,296 Posts
plug the abs and esp back in and center your steering wheel.

could the poor idling could be bad gas? pull your spark plugs and look at them for signs of corrosion/blackness.

if the loss of power when hitting the accelerator is not related to the esp, then there are probably a hundred things that could be causing it.

a steering wheel that is not perfectly centered is almost always the cause of the esp being activated. so, i would start with plugging the esp and abs back in, then making sure the steering wheel is centered, then start to look at what might be causing the power loss (which can be the result of the esp going nuts).

you need to start eliminating variables one at a time.
 

·
Premium Member
Joined
·
15,290 Posts
Stop calling it a car and all your problems will go away.


Do an alignment/ center steering wheel as stated. You can search thru the "modified" section for some tips if unfamiliar with procedure. Engine has relatively low idle but there may be a TSB for low idle as well. Can't remember since there are quite a few. I don't have a link...You can google "jeep jk tsb recalls" and it will come up.
 

·
Registered
Joined
·
6,371 Posts
You can google "jeep jk tsb recalls" and it will come up.
Or you can goto the TSB forum right here on jk owners :bounce:
http://www.jkowners.com/forum/forumdisplay.php?f=47

like the others said, plug your stuff back in!
There's NO reason to have to unplug it if things are done right.
Start by centering your steering wheel, just a little bit off will definitely cause warning lights.
There are plenty of rigs on here with far more radical mods with no esp issues.

Oh yeah, and apologize to it for calling it a car..... :mr-t:


And.... Welcome to the site!
 

·
Registered
Joined
·
1,041 Posts
What do you mean "unplugged" the ABS? Did you hardwire a switch to turn on and off or did you pull something like the f7 fuse? Kind of need to understand how you did this to even determine if this has anything to do with your problem.

I've had your issue before but only when I first start it up and when I take off in 2nd and not 1st gear. Almost a bog down feeling.

ESP feeling will be obvious to most. You can feel it if you gently apply brake pedal.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top