JKOwners Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Well now that its finally hot out, my A/C isn't working. It was fine a few months ago when I was in the Florida Keys, but when I turned it on recently I get no cold air! Its a 14' JKU with 40,800 miles. The last thing done to it was thermostat was replaced and the system was flushed at the dealer. I hoping for something simple or obvious, but I'm no mechanic. Any ideas would be great. Thanks in advance, Joe.
 

·
Registered
Joined
·
101 Posts
blowing - just not cold? They may have evacuated/vented the coolant
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
Yes it's blowing fine, just not cold or even cool air. I've never had A/C in any of my wranglers, so I'm totally not familiar with them. What would the solution be?
 

·
Registered
Joined
·
81 Posts
My JK stopped blowing cold on a trail one day here in Az. I took it to a buddies house who Has a RobinAir AC machine at home and ran the vacuum for 30 minutes and then started to fill. Immediately after we started charging I could here hissing and we were able to find the leak. Like an idiot I mounted my Warn Winch Solenoid box behind the grill and a bolt behind the box was able to make a small hole in the condenser with road vibrations etc.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #5
I'll keep that in mind, been trying to look for leaks anywhere, but so far havent found anything. I was hoping not to have to take it somewhere, but I dont think the wife will appreciate no A/C all summer!
 

·
Registered
Joined
·
83 Posts

·
Registered
Joined
·
12 Posts
have you tried one of these?
Deal Maker Page | AutoZone.com
I tried one of them and it was very helpful.
In general, I don't think I could survive without air conditioning because my body is very pretentious. When it's too hot outside, I like cold, and when it's cold I want warm.
That's why I always go to Egypt in the winter to rest, and in the mountains in the summer.
Last week I had the problem that my conditioner broke down and I was looking for how to fix it. I didn't succeed alone, that's why I turned to the aircon service and they helped me.
 

·
Registered
Joined
·
9 Posts
Well now that its finally hot out, my A/C isn't working. It was fine a few months ago when I was in the Florida Keys, but when I turned it on recently I get no cold air! Its a 14' JKU with 40,800 miles. The last thing done to it was thermostat was replaced and the system was flushed at the dealer. I hoping for something simple or obvious, but I'm no mechanic. Any ideas would be great. Thanks in advance, Joe.
I think the problem is that your air conditioner gas needs a refill. If you have used it for two years without a refill then you should start there. this is not usually an expensive or complicated process.
 
1 - 8 of 8 Posts
Top