JKOwners Forum banner

1 - 20 of 30 Posts

·
Registered
Joined
·
612 Posts
Discussion Starter #1
BAD NEWS
Well, I broke the ABS sensor that mounts to my front left disc assembly. Now my jeep is lighting up like x-mas tree. I was all over the road today from the broken sensor. I think it(Jeep Brain) was thinking I was in a perpetual slide and tried braking the various wheels to compensate. Either way, it was hard to just drive straight.

GOOD NEWS
they only cost $15 per front side :grinpimp: and I pick it up in the morning:D:bounce:



That is all.
 

·
Banned
Joined
·
3,226 Posts
Yah, that was what I was wondering. I may have broke one. My dash is lighting up but I am not experienceing any issues with the system acting up, in fact, just the opposite.

I have to check something else first but I think it is the sensor.
 

·
Registered
Joined
·
235 Posts
I just had mine break when I was replacing the ball joints on the driver side. it just made the abs and esp lights come on. Drove it for 3 days till the new one came in didn't have a problem. Popped the new one in reconnected it drove about 50 ft and all my idiot lights went back off.
 

·
Registered
Joined
·
42 Posts
MUD707,

How did you replace the sensors? I'm pretty sure I broke one on my right rear wheel. My ABS and ESP lights are on after hitting a rock pretty hard.
 

·
Banned
Joined
·
3,226 Posts
MUD707,

How did you replace the sensors? I'm pretty sure I broke one on my right rear wheel. My ABS and ESP lights are on after hitting a rock pretty hard.
  • Remove tire
  • Remove caliper
  • Remove rotor
  • You will see the sensor at this point. Just follow the ABS wire down to where it bolts in just the housing. There is a single Allen head bolt. I forget the size offhand.
  • Remove bolt
  • CAREFULLY remove sensor from housing (they break easily)
  • fanagal it out of the hole in the dust sheild
  • follow the cable up behind the shock tower where you will find a clip to unhook cable
  • Tease your cat for a while with the old wiring
  • reverse directions to install new sensor being super carefull when you insert it and be sure to keep debris from falling in the open hole.
I don't recall if the new ones come pre lubed??
 

·
Registered
Joined
·
113 Posts
I just saw this thread, so after my recent battery replacement which only temporarily solved all my lights going off; I had a code scan done which gave me U1110 and U1120. So now I am pretty sure it is the sensor which is bad, but how do I know which one it is?

Also, does anyone know what the part number is so I know what to order?

thanks
 

·
Registered
Joined
·
494 Posts
mtnmedic, your trouble codes refer to communications over CAN bus C, not the wheel sensors. Wheel sensor problem codes are preceded by the letter C, not U. The FSM says your codes are a problem with the Powertrain control module, the antilock brake module, or the wiring in between. If it was the wiring, you should have a lost communications code too.

To me, it sounds like the ABS module is still confused from having a bad battery. I would try disconnecting the battery for a few minutes to see if that will reset the problem. Did you clear all trouble codes after the battery replacement? Does the ABS system still actually work? How about ESP?
 

·
Registered
Joined
·
113 Posts
mtnmedic, your trouble codes refer to communications over CAN bus C, not the wheel sensors. Wheel sensor problem codes are preceded by the letter C, not U. The FSM says your codes are a problem with the Powertrain control module, the antilock brake module, or the wiring in between. If it was the wiring, you should have a lost communications code too.

To me, it sounds like the ABS module is still confused from having a bad battery. I would try disconnecting the battery for a few minutes to see if that will reset the problem. Did you clear all trouble codes after the battery replacement? Does the ABS system still actually work? How about ESP?
Thanks for your thoughts. I just found my .iso FSM and burned it to a disk this morning but didn't seem to find a reference to the codes. what section did you see it in.

I haven't tried to see if the ABS is still working, but will slam on my brakes on a dirt road tomorrow and see it it activates. It's pretty frustrating as I am outside of my warranty and any stealership is sure to jack me if I cant figure this out.

I'll let you know tomorrow about the ABS.
 

·
Registered
Joined
·
494 Posts
what section did you see it in.
Service Info/9 - Engine/Engine Electrical Diagnostics - Gas/Engine Electrical Diagnostics - Gas/Diagnosis and Testing/

Than manual is a real pain to find anything in.
 

·
Registered
Joined
·
113 Posts
Service Info/9 - Engine/Engine Electrical Diagnostics - Gas/Engine Electrical Diagnostics - Gas/Diagnosis and Testing/

Than manual is a real pain to find anything in.
great thanks, only now internet explorer wont open the files anymore. I hate how you cant use firefox etc. I'll try an reboot and check it out.

thanks again

***nevermind, i figured out I can run it with Firefox in Internet Explorer mode.******

....uh, oh. after following the flow chart in the FSM, it says, "Replace and program the Powertrain Control Module per Service Information."
that cant be good or cheap. F&*k, F#^K, F*@k!
 

·
Registered
Joined
·
494 Posts
Every time I run the FSM, Vista gives me a warning on top of my screen that says "To help protect your security, Internet Explorer has restricted this webpage from running scripts or ActiveX controls that could access your computer. Click here for options". Then I have to allow the blocked content to open the manual.
 

·
Registered
Joined
·
113 Posts
well, I too am running Vista on this machine and 7 on by backup. Luckily the FSM seems to run fine with Firefox in Internet Explorer mode. I remember when I first got the FSM, they said don't update IE because it would only run on pre version 8. i haven't tried it on the Windows 7 machine yet.

Typical chrylser.
 

·
Registered
Joined
·
113 Posts
i would try leaving the battery disconnected overnight
oh, I'm already a pro at doing that. it will clear the codes for a day or so and then sometimes, without even hitting a bump or crack in the road, i get the christmas lights. the lights flash and then the esp, BAS (i think) usually stay on until I turn the jeep off, then when i get it back on, the check engine light is on.

I love driving it when the BRAKE light is on, I always check to make sure the emergency brake didnt somehow pull itself on!
 
1 - 20 of 30 Posts
Top